Custom Tab: Different color for Share option from menu

RESOLVED FIXED in Firefox 55

Status

()

P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: sorina, Assigned: walkingice)

Tracking

(Blocks: 1 bug)

55 Branch
Firefox 55
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

2 years ago
Created attachment 8859619 [details]
2017_04_19_17_25_57_Screenshot_Share.png

Environment: 
Device: Huawei Honor (Android 5.1.1);
Build: Nightly 55.0a1 (2017-04-18);

Steps to reproduce:
1. Launch CustomTab Activity;
2. Long tap on any link from the page or image;
3. Observe the share option.

Expected result:
The options have the same color.

Actual result:
The color for menu-options are not the same.
[triage]
major identifiable UI flaw
Priority: -- → P1
(Assignee)

Comment 2

2 years ago
One of the key points to reproduce this bug is about the toolbar background color, which effects CustomTab to use different theme.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Assignee: nobody → walkingice0204
(Assignee)

Updated

2 years ago
Attachment #8868877 - Attachment is obsolete: true
Attachment #8868877 - Flags: review?(s.kaspari)
(Assignee)

Updated

2 years ago
Attachment #8868878 - Attachment is obsolete: true
Attachment #8868878 - Flags: review?(s.kaspari)
(Assignee)

Updated

2 years ago
Attachment #8868879 - Attachment is obsolete: true
Attachment #8868879 - Flags: review?(s.kaspari)
(Assignee)

Comment 6

2 years ago
Canceled previous patch. I decided just use one Theme(Theme.AppCompat.Light.NoActionBar) in CustomTabs which cause less visual problems. Since CustomTabs re-uses some widgets from Gecko, and there is no dark theme in Gecko. If I apply dark theme in CustomTabs, I might(already) bite myself.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 13

2 years ago
mozreview-review
Comment on attachment 8869530 [details]
Bug 1357780 - CustomTabs get rid of dark theme

https://reviewboard.mozilla.org/r/141122/#review144882
Attachment #8869530 - Flags: review?(s.kaspari) → review+

Comment 14

2 years ago
mozreview-review
Comment on attachment 8869531 [details]
Bug 1357780 - Fix tint problem in Android 4.4

https://reviewboard.mozilla.org/r/141124/#review144884
Attachment #8869531 - Flags: review?(s.kaspari) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 15

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7823d414f9d7
CustomTabs get rid of dark theme r=sebastian
https://hg.mozilla.org/integration/autoland/rev/d5db05712359
Fix tint problem in Android 4.4 r=sebastian
Keywords: checkin-needed

Comment 16

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7823d414f9d7
https://hg.mozilla.org/mozilla-central/rev/d5db05712359
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
You need to log in before you can comment on or make changes to this bug.