Closed Bug 1357841 Opened 3 years ago Closed 3 years ago

The status panel does not mirror on non-e10s content

Categories

(Firefox :: General, defect)

55 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox53 --- unaffected
firefox54 --- wontfix
firefox55 --- fixed

People

(Reporter: jaws, Unassigned)

References

Details

(Whiteboard: [fixed by backout of bug 1356183])

STR:
Open about:newtab and reduce the height of the browser window so one of the new tab thumbnails is clipped by the bottom of the window.
Hover over the left-most (on a LTR setup)

Expected results:
The status panel should not overlap the mouse cursor

Actual results:
The status panel appears on the left-side and beneath the mouse cursor. It should mirror to the other side.
Confirmed via mozregression that bug 1356183 introduced this. I used about:about to test.
Given the platforms patches that landed in bug 1307134, should we consider backing out bug 1356183?
(In reply to Florian Quèze [:florian] [:flo] from comment #2)
> Given the platforms patches that landed in bug 1307134, should we consider
> backing out bug 1356183?

Maybe, but I think we should also investigate what's wrong with clientX. This seems like a platform bug. In fact it's probably why bug 646038 wasn't using clientX in the first place...
Component: General → DOM: Core & HTML
Flags: needinfo?(tnikkel)
Product: Firefox → Core
Summary: The status panel does not mirror on XUL pages → The status panel does not mirror on non-e10s content
Is what clientX is relative to in e10s different from non-e10s? The event is dispatched to the same window? I don't really know this event stuff well.
Flags: needinfo?(tnikkel)
(In reply to Timothy Nikkel (:tnikkel) from comment #4)
> Is what clientX is relative to in e10s different from non-e10s?

Yeah.

> The event is dispatched to the same window? I don't really know this event stuff well.

For non-e10s the event is dispatched on content nodes, and the numbers make sense for any content listener but seem weird for chrome listeners. For e10s or when moving the mouse pointer over the browser chrome, the numbers become relative to the browser window.
Sounds like browser/toolkit bug to me then.
Okay, backed out: https://hg.mozilla.org/integration/mozilla-inbound/rev/f18e288534fbc91b47a4d11a25409fdae274a1d2

Not going to back this out from 54 unless bug 1307134 gets uplifted too.
Status: NEW → RESOLVED
Closed: 3 years ago
Component: DOM: Core & HTML → General
Product: Core → Firefox
Resolution: --- → FIXED
Looks like the fix is going to apply for 55 but we will still have this bug in 54.
Whiteboard: [fixed by backout of bug 1356183]
You need to log in before you can comment on or make changes to this bug.