forbid LLVM >= 4.0 for being used for stylo bindgen (require llvm39)

RESOLVED FIXED in Firefox 55

Status

()

Core
Build Config
RESOLVED FIXED
a month ago
20 days ago

People

(Reporter: froydnj, Assigned: froydnj)

Tracking

(Blocks: 2 bugs)

unspecified
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

(Whiteboard: [stylo])

Attachments

(1 attachment)

(Assignee)

Description

a month ago
Released versions of LLVM 4.0 do not work properly with bindgen, and the
in-development 5.0 version doesn't either.  To avoid undue hair-pulling,
we should detect such versions early during configure and advise the
user about appropriate versions.
(Assignee)

Comment 1

a month ago
Created attachment 8859737 [details] [diff] [review]
forbid LLVM >= 4.0 for being used for stylo bindgen

A small quality-of-life improvement for people getting started with Stylo.
Attachment #8859737 - Flags: review?(giles)
Comment on attachment 8859737 [details] [diff] [review]
forbid LLVM >= 4.0 for being used for stylo bindgen

Review of attachment 8859737 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8859737 - Flags: review?(giles) → review+

Comment 3

a month ago
Pushed by nfroyd@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/346c7bcd0ef9
forbid LLVM >= 4.0 for being used for stylo bindgen; r=rillian
Blocks: 1356991, 1345321
Summary: forbid LLVM >= 4.0 for being used for stylo bindgen → forbid LLVM >= 4.0 for being used for stylo bindgen (require llvm39)
Whiteboard: [stylo]
https://hg.mozilla.org/mozilla-central/rev/346c7bcd0ef9
Status: NEW → RESOLVED
Last Resolved: a month ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
See Also: → bug 1363666
You need to log in before you can comment on or make changes to this bug.