Port bug 1354002 - Set execCommand("defaultparagraphseparator", false, "br/p") depending on mail.compose.default_to_paragraph to SeaMonkey

RESOLVED FIXED in seamonkey2.53

Status

SeaMonkey
MailNews: Composition
RESOLVED FIXED
4 months ago
27 days ago

People

(Reporter: Ian Neal, Assigned: Ian Neal)

Tracking

(Blocks: 1 bug)

Trunk
seamonkey2.53

SeaMonkey Tracking Flags

(seamonkey2.52 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

4 months ago
Created attachment 8859774 [details] [diff] [review]
Add mail.compose.default_to_paragraph check [Checked in: Comment 2]

Simple port of TB patch
Attachment #8859774 - Flags: review?(frgrahl)
Attachment #8859774 - Flags: review?(frgrahl) → review+
(Assignee)

Updated

4 months ago
Keywords: checkin-needed
(Assignee)

Updated

4 months ago
status-seamonkey2.52: --- → fixed
Keywords: checkin-needed
Target Milestone: --- → seamonkey2.52
(Assignee)

Comment 2

4 months ago
Comment on attachment 8859774 [details] [diff] [review]
Add mail.compose.default_to_paragraph check [Checked in: Comment 2]

https://hg.mozilla.org/comm-central/rev/d67289948650
Attachment #8859774 - Attachment description: Add mail.compose.default_to_paragraph check → Add mail.compose.default_to_paragraph check [Checked in: Comment 2]
(Assignee)

Updated

4 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED

Comment 3

4 months ago
Sorry, I had to back this out since it's causing unwanted side-effects in replies, see bug 1354002 comment #11. I've also backed out that bug.
https://hg.mozilla.org/comm-central/rev/38b43436a7c0fcb28c3d260091f1572646ba3c61
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 4

2 months ago
I've done some more work in this in bug 1354002, including some mailnews changes. So this got now relanded, but with an additional hunk since in paragraph mode mailnews now no longer produces "br"s.

Can someone please check that all is well in SM.

https://hg.mozilla.org/comm-central/rev/064ea09a484db674bea276f4f634dd9b7bf85d24

I've also moved the target forward to SM 2.53 which equates TB 56.
Status: REOPENED → RESOLVED
Last Resolved: 4 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: seamonkey2.52 → seamonkey2.53
Flags: needinfo?(frgrahl)
I am now testing this for a while and the current behaviour it to swallow blank lines at the end of a parapraph. Not reopening it. Can't tell if this patch or something else caused it and no time to nail it down right now.
Flags: needinfo?(frgrahl)

Comment 6

27 days ago
I'm happy with the behaviour of TB after bug 1354002 got landed:
https://hg.mozilla.org/comm-central/rev/dd97865d7a80a00490e1cf1226b05ca6d2fe18bc
I haven't seen any bad effects.

What do you mean by "swallow blank lines at the end of a paragraph"?
I am seeing this mostly in newsgroup text only posts. It seems blank lines get removed where a br in html posts should/would be inserted. Just an uneducated guess right now because I am not that firm with this code and prefs. I am filing it under issue 999 right now until I find more time to check my settings and analyse the raw data. 

Just check my latest post in mozilla.dev.apps.seamonkey as an example.

> Re: l10n.mozilla-community.org?

> https://bugzilla.mozilla.org/show_bug.cgi?id=1383642
> FRG

Missing the blank line between the link and frg which was there during compose.

Comment 8

27 days ago
Hmm, I tried a few scenarios and didn't lose any blank line.

Can you reproduce the problem? If so, can you save the message as a draft and attach it here?
Also make sure that editing the draft and then sending it will reproduce the problem.
You need to log in before you can comment on or make changes to this bug.