Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Fix network-details-panel-toggle direction in vertical mode

VERIFIED FIXED in Firefox 55

Status

()

Firefox
Developer Tools: Netmonitor
P3
normal
VERIFIED FIXED
3 months ago
29 days ago

People

(Reporter: magicp, Assigned: Michael Brennan)

Tracking

({good-first-bug})

Trunk
Firefox 56
good-first-bug
Points:
---

Firefox Tracking Flags

(firefox55 verified, firefox56 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 months ago
Created attachment 8859803 [details]
network-details-panel-toggle.png

[Steps to reproduce]
1. Start Nightly
2. Open net monitor (docking to side and vertical mode)
3. Go to any sites
4. Confirm direction of network-details-panel-toggle

[Actual Results]
network-details-panel-toggle direction is left or right.

[Expected Results]
network-details-panel-toggle direction is up or down in vertical mode.
Thanks for the report!

Honza
Priority: -- → P3
Keywords: good-first-bug
(Assignee)

Updated

3 months ago
Assignee: nobody → brennan.brisad
(Assignee)

Comment 2

3 months ago
Created attachment 8865014 [details] [diff] [review]
bug1357964.patch
Attachment #8865014 - Flags: review?(odvarko)
Comment on attachment 8865014 [details] [diff] [review]
bug1357964.patch

Review of attachment 8865014 [details] [diff] [review]:
-----------------------------------------------------------------

Works great for me, thanks for the patch!

Honza
Attachment #8865014 - Flags: review?(odvarko) → review+
Status: NEW → ASSIGNED
(Assignee)

Updated

a month ago
Keywords: checkin-needed

Comment 4

a month ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/03f93e71d647
Rotate network-details-panel-toggle button in vertical mode. r=honza
Keywords: checkin-needed

Comment 5

a month ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/03f93e71d647
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
I have reproduced this bug with nightly 55.0a1 (2017-04-19) on "Linux Mint 18.1 Serena"(64 Bit).

The bug's fix is now verified on Latest Nightly 56.0a1.

Build ID 	20170614100332
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

[Bugday-20170614]

Comment 7

a month ago
I have reproduced this bug with Nightly 55.0a1 (2017-04-19) on Windows 10 , 64 Bit ! 

This bug's fix is Verified with latest Nightly 56.0a1 !

Build   ID    20170614030206
User Agent    Mozilla/5.0 (Windows NT 10.0; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170614]
As per Comment 6 & Comment 7, I am marking this bug as verified fixed
Status: RESOLVED → VERIFIED
status-firefox56: fixed → verified
Is this a regression in the new net monitor?  Do we want to fix this in 55?
Flags: needinfo?(odvarko)
Comment on attachment 8865014 [details] [diff] [review]
bug1357964.patch

Approval Request Comment
[Feature/Bug causing the regression]: not specified
[User impact if declined]: wrong icon for a button
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: yes, see comment #0
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: no
[Why is the change risky/not risky?]: just CSS change
[String changes made/needed]: n/a
Flags: needinfo?(odvarko)
Attachment #8865014 - Flags: approval-mozilla-beta?
Comment on attachment 8865014 [details] [diff] [review]
bug1357964.patch

css fix for netmonitor, beta55+
Attachment #8865014 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 12

a month ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/00c04e6496ed
status-firefox55: affected → fixed
QA Whiteboard: [bugday-20170614] → [bugday-20170614] [good first verify]

Comment 13

29 days ago
The issue is no longer reproducible on Firefox 55.0b4.
Build ID: 20170622104007
Tests were performed under Windows 10x64.
[Firefox 55 Beta 4 Testday - 20170623]
status-firefox55: fixed → verified
You need to log in before you can comment on or make changes to this bug.