Permaorange test_bug877690.html | property float's values when Gecko 55 merges to beta on 2017-06-12

RESOLVED FIXED in Firefox 55

Status

()

Firefox
Developer Tools: CSS Rules Inspector
P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: philor, Unassigned)

Tracking

55 Branch
Firefox 55
Points:
---

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55+ fixed)

Details

(Reporter)

Description

a year ago
I must be missing something, since only bug 1156019 has touched it during the 55 cycle, and it doesn't seem to have touched anything to do with float, but https://treeherder.mozilla.org/logviewer.html#?job_id=92882784&repo=try (which you should be able to reproduce locally by just changing /config/milestone.txt from 55a1 to 55) says that test_bug877690.html is going to be permaorange when we merge to beta the next time.

[Tracking Requested - why for this release]:

Merge bustage, closed tree, delayed b1, sadness.
(Reporter)

Updated

a year ago
Flags: needinfo?(ttromey)
Tracking 55+ for this permaorange, especially to avoid delays in B1.
tracking-firefox55: ? → +

Comment 2

a year ago
I thought we had a plan in place whereby the tests would be more lenient in
situations like this.  However, I don't really recall the details, so I'm
forwarding this to Greg.
Flags: needinfo?(ttromey) → needinfo?(gtatum)
This is similar to the stuff I was doing with the static css database, but this appears to be a different test. I'm not sure the history on it. It's failing because float inline-end and float inline-start are both disabled on beta, but enabled on Aurora. The way I solved it was disabling on platforms that change, e.g. the test was only enabled on nightly. The only other option would be to make those two properties optional in the test.
Flags: needinfo?(gtatum)
DevTools bug triage (filter on CLIMBING SHOES).
Priority: -- → P1
(Reporter)

Comment 5

a year ago
Probably the easiest way to fix it, though, would be to ship float: inline-(start|end).

Fixed by bug 1253919.
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox55: affected → fixed
Depends on: 1253919
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
You need to log in before you can comment on or make changes to this bug.