Closed Bug 1358368 Opened 4 years ago Closed 4 years ago

Intermittent toolkit/components/places/tests/favicons/test_root_icons.js | test_removePagesByTimeframe - [test_removePagesByTimeframe : 84] There should be no icon entry - 1 == 0

Categories

(Toolkit :: Places, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mak)

Details

(Keywords: intermittent-failure, Whiteboard: [fxsearch])

Attachments

(1 file)

Taking for investigation
Assignee: nobody → mak77
Priority: -- → P2
Whiteboard: [fxsearch]
my only suspect so far is that the concurrent connection is reading from the db while the db is checkpointing the change, that means it reads an outdated snapshot. adding a promiseUpdatePlaces may do in such a case.
I cannot reproduce locally.
Comment on attachment 8860343 [details]
Bug 1358368 - Ensure we read values from a current db snapshot in places/tests/favicons/test_root_icons.js.

https://reviewboard.mozilla.org/r/132386/#review135260

This seems reasonable to try. r=Standard8
Attachment #8860343 - Flags: review?(standard8) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/dea1c646413a
Ensure we read values from a current db snapshot in places/tests/favicons/test_root_icons.js. r=standard8
https://hg.mozilla.org/mozilla-central/rev/dea1c646413a
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.