1.03ms uninterruptible reflow at _moveItemsBackToTheirOrigin@resource:///modules/CustomizableUI.jsm:4203:1

RESOLVED FIXED in Firefox 61

Status

()

defect
P4
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: rjward0, Assigned: Gijs)

Tracking

(Blocks 1 bug, {perf})

unspecified
Firefox 61
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox61 fixed)

Details

(Whiteboard: [ohnoreflow][qf:p3][fxperf:p3])

Reporter

Description

2 years ago
Here's the stack:

_moveItemsBackToTheirOrigin@resource:///modules/CustomizableUI.jsm:4203:1
_onLazyResize@resource:///modules/CustomizableUI.jsm:4251:7
asyncFunction@resource://gre/modules/Task.jsm:241:18
Task_spawn@resource://gre/modules/Task.jsm:166:12
_timerCallback/<@resource://gre/modules/DeferredTask.jsm:277:13
TaskImpl_run@resource://gre/modules/Task.jsm:319:42
TaskImpl@resource://gre/modules/Task.jsm:277:3
asyncFunction@resource://gre/modules/Task.jsm:252:14
Task_spawn@resource://gre/modules/Task.jsm:166:12
_timerCallback@resource://gre/modules/DeferredTask.jsm:275:29
Component: Untriaged → Toolbars and Customization
Flags: qe-verify?
Priority: -- → P2
I'm not familiar with this code, so I have no suggestion about how to fix this, but the sync reflow seems caused by the .clientWidth getter at http://searchfox.org/mozilla-central/rev/7aa21f3b531ddee90a353215bd86e97d6974e25b/browser/components/customizableui/CustomizableUI.jsm#4203
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p3][photon-performance]
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p3][photon-performance] → [ohnoreflow][qf:p3][reserve-photon-performance]
Flags: qe-verify? → qe-verify-
Assignee

Updated

2 years ago
See Also: → 1373054
Priority: P3 → P4
Keywords: perf
Whiteboard: [ohnoreflow][qf:p3][reserve-photon-performance] → [ohnoreflow][qf:p3][fxperf]
Whiteboard: [ohnoreflow][qf:p3][fxperf] → [ohnoreflow][qf:p3][fxperf:p3]
Assignee

Updated

a year ago
Depends on: 1447619
Assignee

Comment 2

a year ago
Fixed in bug 1447619. \o/
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
You need to log in before you can comment on or make changes to this bug.