Elements with role="region" and no accessible name should be mapped according to host language

RESOLVED FIXED in Firefox 56

Status

()

RESOLVED FIXED
a year ago
9 months ago

People

(Reporter: jdiggs, Assigned: jdiggs)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

unspecified
mozilla56
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
Steps to reproduce:
1. Load data:text/html,<div role="region">foo</div>
2. Use Accerciser to examine the element

Expected results: the element would have ROLE_SECTION
Actual results: the element has ROLE_PANEL

The Core AAM states: "Special case: if the region does not have an accessible name, do not expose the element as a landmark. Use the native host language role of the element instead." https://rawgit.com/w3c/aria/master/core-aam/core-aam.html#role-map-region
Blocks: 343213
(Assignee)

Comment 1

a year ago
Making this a depends on bug 1378160 because my patch-in-progress to handle the no-name scenario described here assumes the thing is a landmark; not a pane. And it won't be a landmark until 1378160 is addressed.
Depends on: 1378160
(Assignee)

Comment 2

a year ago
Created attachment 8883431 [details] [diff] [review]
proposed patch

Note that this patch expects/requires the patch for bug 1378160. The fix for that bug is where roles::REGION (used here) gets added to Gecko.
Assignee: nobody → jdiggs
Status: NEW → ASSIGNED
Attachment #8883431 - Flags: review?(mzehe)

Updated

a year ago
Attachment #8883431 - Flags: review?(mzehe) → review+
(Assignee)

Updated

a year ago
Keywords: checkin-needed

Comment 3

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2286518951eb
Elements with role="region" and no accessible name should be mapped according to host language. r=MarcoZ
Keywords: checkin-needed

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2286518951eb
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Blocks: 1420773
No longer blocks: 1420773
Depends on: 1420773
You need to log in before you can comment on or make changes to this bug.