Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Native form validation error messages do not appear

RESOLVED FIXED

Status

()

Core
DOM: Core & HTML
P3
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: Peter-Paul Koch, Unassigned)

Tracking

({dev-doc-complete, regression, site-compat})

53 Branch
dev-doc-complete, regression, site-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53+ fixed, firefox54 fixed, firefox55 fixed, firefox-esr45 unaffected, firefox-esr52 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
Created attachment 8860392 [details]
Simple test form which ought to show a validation error message when the user hits Submit.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

Steps to reproduce:

See https://quirksmode.org/dom/forms/firefoxbug.html. Simple test form which ought to show a validation error message when the user hits Submit. File also attached.

New bug since Firefox 53. The test works fine in 52.


Actual results:

On submit the field shows no error message.


Expected results:

On submit the field shows the error message.
I can reproduce this with a clean profile in 53, but not in a clean profile in 54.

Mike, do you know where the best place for this bug to live is?
Flags: needinfo?(mconley)
Keywords: regression, regressionwindow-wanted
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug 345624 was where the initial work to support validation was done, and that was in Core :: DOM: Core & HTML, so let's put it there for now.
Component: Untriaged → DOM: Core & HTML
Flags: needinfo?(mconley)
Product: Firefox → Core

Comment 3

3 months ago
Regression window in beta:
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=a5ccc32310c9a424ccb4f5106f5155ca20dd360a&tochange=ea823a8262ac96b7150df0a41beb2ba5e40fe89c

Regression window in inbound:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5b38cc764e9012ec544cc3b150c35db706e34ced&tochange=d280a7a149bba92ecdb59b9de0a0336c336de889

Regressed by: Bug 1109868

Fixed window in autoland:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=dbc95156d490db31e79770dbb245cf7bb06e2b09&tochange=0ee3593e23151e498f26f7fb9af07035272ebbce

Fixed by: Bug 1341190
Blocks: 1109868
status-firefox53: --- → affected
status-firefox54: --- → fixed
status-firefox55: --- → fixed
status-firefox-esr45: --- → unaffected
status-firefox-esr52: --- → unaffected
Depends on: 1341190
Keywords: regressionwindow-wanted

Comment 4

3 months ago
Mozilla forgot to uplift Bug 1341190 to 53  :(
Thanks for finding the regression bug Alice0775! 

Not sure what our options are here short of living with this regression until 54 ships. Liz, something to put on the radar in case we ship a dot release? Kind of sucks to break html5 form validation UI.
Flags: needinfo?(lhenry)
(Reporter)

Comment 6

3 months ago
Since I'm writing an article on this topic and I have to say something about this bug, it is fair to say that this is a bug in Firefox 53 that does not occur in either 52 or 54, correct?

Updated

3 months ago
Duplicate of this bug: 1358511
> it is fair to say that this is a bug in Firefox 53 that does not occur in either 52 or 54, correct?

That sounds correct. It's hard to say if this might be fixed in an upcoming 53 dot release or not (release management will have to decide), but it's def. fixed in 54.
Posted the site compatibility note: https://www.fxsitecompat.com/en-CA/docs/2017/form-validation-error-messages-disappear-quickly/

[Tracking Requested - why for this release]: A site compatibility regression affecting certain web forms using the validation API properly. The patch in Bug 1341190 seems one-liner CSS; the uplift risk should be very low.
tracking-firefox53: --- → ?
Keywords: dev-doc-complete, site-compat
Yes, this looks like a great candidate for a 53 dot release if we do one, which is likely.
tracking-firefox53: ? → +
Flags: needinfo?(lhenry)

Updated

3 months ago
Duplicate of this bug: 1358788
Priority: -- → P3

Comment 12

3 months ago
Been over a week now. Any updates on if this is going to be a dot release?
ni? for comment 12
Flags: needinfo?(lhenry)
Handling this now in bug 1341190 where the uplift request is.
Flags: needinfo?(lhenry)
Fixed with Firefox 53.0.2 shipped today.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
status-firefox53: affected → fixed
You need to log in before you can comment on or make changes to this bug.