Closed Bug 1358502 Opened 3 years ago Closed 3 years ago

Update harfbuzz to version 1.4.6 [was: IPA Characters Overlap When Entering Text on 64-bit Windows systems]

Categories

(Core :: Graphics: Text, defect, P3)

47 Branch
x86_64
Windows
defect

Tracking

()

VERIFIED FIXED
mozilla55
Tracking Status
firefox-esr52 --- wontfix
firefox53 --- wontfix
firefox54 --- fixed
firefox55 --- verified

People

(Reporter: zstimi, Assigned: jfkthame)

References

Details

(Keywords: regression)

Attachments

(1 file)

Follow up for bug 1279925, to track the remaining issues for 64-bit systems, (Windows 10 x64 and Windows 8.1 x64). 

For more details please see https://bugzilla.mozilla.org/show_bug.cgi?id=1279925#c53 and https://bugzilla.mozilla.org/show_bug.cgi?id=1279925#c44

Steps to reproduce:
1. Open page : https://bugzilla.mozilla.org/attachment.cgi?id=8762563

Actual results:

The characters ː and ˈ end up overlapping with the next character that is entered. It looks almost as though they are treated like Right-to-Left characters. 

Expected results:

The characters should show up in the sequence in which they are entered. These are not combining characters and should not overlap.
ni? Jonathan to have a look for this bug.
Has STR: --- → yes
Flags: needinfo?(jfkthame)
Priority: -- → P3
Timea, when you said in bug 1279925 comment 44 that this bug affects Windows 10 x64, are you testing 64-bit Firefox and/or 32-bit Firefox builds? I wonder whether this bug affects any Firefox running on 64-bit Windows OS or just 64-bit Firefox builds.
Flags: needinfo?(timea.zsoldos)
Yes, I tested both Firefox builds, 64-bit and 32-bit too, and I confirm that the issue is reproduce on 32-bit Firefox builds too.
Flags: needinfo?(timea.zsoldos)
This is dependent on the exact version of Tahoma installed on the system, not on the specific Firefox build.

A workaround is included in harfbuzz 1.4.6, which was just released a few hours ago; so we need to update the library and that should resolve the problem.
Flags: needinfo?(jfkthame)
Pretty minor HB update; includes the GDEF blacklist entries for additional versions of Tahoma to fix the problem reported here.
Attachment #8860888 - Flags: review?(jmuizelaar)
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
Summary: IPA Characters Overlap When Entering Text on 64-bit Windows systems → Update harfbuzz to version 1.4.6 [was: IPA Characters Overlap When Entering Text on 64-bit Windows systems]
Duplicate of this bug: 1359100
(In reply to Timea Zsoldos from comment #3)
> Yes, I tested both Firefox builds, 64-bit and 32-bit too, and I confirm that
> the issue is reproduce on 32-bit Firefox builds too.

Thanks. That means this bug doesn't need to block our rollout of 64-bit Firefox builds to more users.

btw, harfbuzz 1.4.6 also includes the upstream fixes for clang's -Wcomma compiler warnings from bug 1356843 comment 61.
Blocks: Wcomma
No longer blocks: win64-rollout
review ping...?
Flags: needinfo?(jmuizelaar)
Attachment #8860888 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/af1ace67caaa
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Ready for Beta/ESR52 approval requests? :)
Flags: needinfo?(jmuizelaar) → needinfo?(jfkthame)
I can confirm this issue is fixed, I verified using Firefox 55.0a1 (both Firefox build 64-bit and 32-bit) on Win 8.1 x64 and Win 10 x64.
Status: RESOLVED → VERIFIED
Comment on attachment 8860888 [details] [diff] [review]
Update harfbuzz to release 1.4.6

Approval Request Comment
[Feature/Bug causing the regression]: bad fonts shipped with specific Windows versions
[User impact if declined]: buggy rendering of certain characters in Tahoma font
[Is this code covered by automated tests?]: it's exercised in the course of font/text tests, but the specific fixes here are not explicitly tested (too dependent on specific installed font versions)
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: just minor changes in new upstream lib version
[String changes made/needed]: none
Flags: needinfo?(jfkthame)
Attachment #8860888 - Flags: approval-mozilla-beta?
(In reply to Ryan VanderMeulen [:RyanVM] from comment #11)
> Ready for Beta/ESR52 approval requests? :)

I marked it for approval-beta? consideration; I doubt this really meets the criteria for ESR uplift, does it?
Comment on attachment 8860888 [details] [diff] [review]
Update harfbuzz to release 1.4.6

Fix certain characters in Tahoma font rendering issue and was verified. Beta54+. Should be in 54 beta 7.
Attachment #8860888 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
ESR52 is on version 1.4.1 still, so yeah, I guess I agree with you on this if we haven't done other updates either.
(In reply to Jonathan Kew (:jfkthame) from comment #13)
> [Is this code covered by automated tests?]: it's exercised in the course of
> font/text tests, but the specific fixes here are not explicitly tested (too
> dependent on specific installed font versions)
> [Has the fix been verified in Nightly?]: yes
> [Needs manual test from QE? If yes, steps to reproduce]: no

Setting qe-verify- based on Jonathan's assessment on manual testing needs and the fact that the area affected by this fix has automated coverage.
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.