1.28ms uninterruptible reflow at _adjustFocusAfterTabSwitch@chrome://browser/content/tabbrowser.xml:1355:9

RESOLVED FIXED in Firefox 55

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
10 months ago

People

(Reporter: mconley, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
Firefox 55
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p2][reserve-photon-performance])

Here's the stack:

_adjustFocusAfterTabSwitch@chrome://browser/content/tabbrowser.xml:1355:9
updateDisplay@chrome://browser/content/tabbrowser.xml:4036:21
postActions@chrome://browser/content/tabbrowser.xml:4143:15
handleEvent@chrome://browser/content/tabbrowser.xml:4457:15
Flags: qe-verify?
Priority: -- → P2
Component: Untriaged → Tabbed Browser
Another case where moving the focus causes a sync flush.
Depends on: 1356034
Reporter

Updated

2 years ago
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p1][photon-performance]
Flags: qe-verify? → qe-verify-
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p1][photon-performance] → [ohnoreflow][qf:p1][reserve-photon-performance]
Whiteboard: [ohnoreflow][qf:p1][reserve-photon-performance] → [ohnoreflow][qf:p2][reserve-photon-performance]
I can no longer reproduce a reflow in this codepath since bug 1369140 landed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Iteration: --- → 55.7 - Jun 12
Priority: P3 → P1
See Also: → 1462374
You need to log in before you can comment on or make changes to this bug.