1.09ms uninterruptible reflow at _customizationEnding@chrome://browser/content/browser-customization.js:98:5

RESOLVED FIXED in Firefox 55

Status

()

Firefox
Toolbars and Customization
P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Robbie Ward, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 55
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p3][reserve-photon-performance])

(Reporter)

Description

a year ago
Here's the stack:

_customizationEnding@chrome://browser/content/browser-customization.js:98:5
handleEvent@chrome://browser/content/browser-customization.js:21:9
_dispatchToolboxEventToWindow@resource:///modules/CustomizableUI.jsm:2116:5
dispatchToolboxEvent@resource:///modules/CustomizableUI.jsm:2121:7
dispatchToolboxEvent@resource:///modules/CustomizableUI.jsm:3691:5
exit/<@resource:///modules/CustomizeMode.jsm:501:7
TaskImpl_run@resource://gre/modules/Task.jsm:319:42
process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:922:23
walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:806:7
Promise*scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:739:11
schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:770:7
completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:707:7
deferredUnwrapToolbarItem/</<@resource:///modules/CustomizeMode.jsm:952:9
Component: Untriaged → Toolbars and Customization
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p3][photon-performance]
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p3][photon-performance] → [ohnoreflow][qf:p3][reserve-photon-performance]
Flags: qe-verify? → qe-verify-
I can no longer reproduce a reflow in this codepath since bug 1369140 landed.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Iteration: --- → 55.7 - Jun 12
Priority: P3 → P1
You need to log in before you can comment on or make changes to this bug.