Closed Bug 1358763 Opened 5 years ago Closed 5 years ago

Crash in mozilla::layers::PUiCompositorController::Transition

Categories

(GeckoView :: General, defect)

55 Branch
Unspecified
Android
defect
Not set
critical

Tracking

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed

People

(Reporter: calixte, Assigned: rbarker)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, topcrash, Whiteboard: [clouseau])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-629458c0-a4c3-42cf-992f-4517a0170421.
=============================================================

There are 24 crashes in nightly 55 with buildid 20170421135915. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1335895.
This signature is ranked #3 in topcrash.

[1] https://hg.mozilla.org/mozilla-central/rev?node=81de9d1439b0e352729142f6aa2914674073da03
Flags: needinfo?(rbarker)
Crash Signature: [@ mozilla::layers::PUiCompositorController::Transition] → [@ mozilla::layers::PUiCompositorController::Transition] [@ mozilla::layers::APZCTreeManager::InitializeDynamicToolbarAnimator ]
Crash Signature: [@ mozilla::layers::PUiCompositorController::Transition] [@ mozilla::layers::APZCTreeManager::InitializeDynamicToolbarAnimator ] → [@ mozilla::layers::PUiCompositorController::Transition] [@ mozilla::layers::APZCTreeManager::InitializeDynamicToolbarAnimator ] [@ libart.so@0x31a66b ]
It looks like the CompositorVsyncScheduler is firing after the IPC channel has shutdown. The UiCompositorControllerParent is then trying to write to a dead IPC channel. I assume this is happen at shutdown. I'll need to talk with some one better versed in our IPC stack on Monday(22/4/17) to figure out the correct solution.
Flags: needinfo?(rbarker)
Assignee: nobody → rbarker
Comment on attachment 8861155 [details]
Bug 1358763 - Prevent Android Dynamic Toolbar v3 from trying to send IPC message after shutdown

https://reviewboard.mozilla.org/r/133108/#review135926
Attachment #8861155 - Flags: review?(bugmail) → review+
Pushed by rbarker@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/85427dbc69bd
Prevent Android Dynamic Toolbar v3 from trying to send IPC message after shutdown r=kats
I was not able to reproduce this crash locally, however based on the stack trace the patch pushed looks like a possible fix. Please reopen if crash persists.
https://hg.mozilla.org/mozilla-central/rev/85427dbc69bd
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Please file a new bug. It gets confusing if you reopen bugs where patches have already landed.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Ok, I just took into account comment 5.
This is actually a different crash than the one originally one reported in this bug.
(In reply to Calixte Denizet (:calixte) from comment #9)
> Ok, I just took into account comment 5.

Is there a new bug for this? Should be an easy fix.
Flags: needinfo?(cdenizet)
Blocks: 1369298
Product: Firefox for Android → GeckoView
Target Milestone: Firefox 55 → mozilla55
You need to log in before you can comment on or make changes to this bug.