“You’re using a pre-release version of Firefox.” sounds and looks like an error message

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: nicolas, Unassigned)

Tracking

({nightly-community})

Production
nightly-community

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170422100218

Steps to reproduce:

I’m using Nightly. I visited https://mozilla.org/firefox/new/


Actual results:

The top right corner of the page displays an exclamation mark in an orange disc (warning symbol) accompanied by the words: “You’re using a pre-release version of Firefox.”

It makes it sounds and looks like if it’s bad.


Expected results:

The symbol should denotes something positive. It could be the (I assume) green check mark of an up-to-date Firefox, or something else. At least not one that seems to has been designed (still assuming) for out-of-date Firefox.

The copy should be positive too. Just ending with “Thanks for testing!” could be enough.

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nightly-community
I believe the wording was made this way intentionally because there are a lot of users on Beta for example, who do not actually realise they are on a pre-release version. It is there to try and make very clear that they can switch to the more stable release channel if they wish to do so. I think Nightly users are likely much more aware of the channel they are on, and also a more niche audience.
Hi Pascal, given Comment 1 I'm going to close this as WONTFIX. It is made to look like a warning for users who are mostly not as technical as the Nightly community. If users are aware they are on a pre-release channel (such as Nightly), I think they are also likely to understand why we might want to call that out explicitly on this page, which is meant for a very different and much broader audience.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.