Closed Bug 1358850 Opened 3 years ago Closed 3 years ago

Building on OS X Yosemite fails: "thread-local storage is not supported for the current target"

Categories

(Core :: XPCOM, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1357897

People

(Reporter: mconley, Unassigned)

References

Details

I pulled from mozilla-central today, and I can't seem to build.

The error appears to be:

"error: thread-local storage is not supported for the current target"

I don't seem to recall anything strange happening with my configuration lately, although I was recently building for Fennec (but have switched my mozconfig to build Firefox Desktop again).

What can I do so I can build again? Please help.

Here's the build error in context:

 1:09.46 In file included from /Users/mikeconley/Projects/mozilla-central/js/src/builtin/RegExp.cpp:7:
 1:09.46 In file included from /Users/mikeconley/Projects/mozilla-central/js/src/builtin/RegExp.h:10:
 1:09.46 In file included from /Users/mikeconley/Projects/mozilla-central/js/src/vm/RegExpObject.h:13:
 1:09.46 /Users/mikeconley/Projects/mozilla-central/js/src/jscntxt.h:74:8: error: thread-local storage is not supported for the current target
 1:09.46 extern MOZ_THREAD_LOCAL(JSContext*) TlsContext;
 1:09.47        ^
 1:09.47 /Users/mikeconley/Projects/mozilla-central/obj-x86_64-apple-darwin14.5.0/dist/include/mozilla/ThreadLocal.h:185:32: note: expanded from macro 'MOZ_THREAD_LOCAL'
 1:09.47 #define MOZ_THREAD_LOCAL(TYPE) thread_local mozilla::detail::ThreadLocal<TYPE>
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1357897
Now that bug 1357897 is fixed, I have brew uninstalled llvm@3.9 (my original solution in comment 1), and all is well again.
You need to log in before you can comment on or make changes to this bug.