Add an option to choose sidebar position

RESOLVED DUPLICATE of bug 1355331

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 1355331
a year ago
a year ago

People

(Reporter: MikkCZ, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

In bug 1355331 has been implemented default sidebar position on the right side. If Firefox wants to be a customizable browser, it should add an option into the UI to move the sidebar to the left.

Comment 1

a year ago
yes please.
I usually add new bookmarks by dragging the icon from url bar to the sidebar (it's the major reason to use firefox for me)
now it's too difficult because I have to drag the icon across all of the screen to the right.
with a mouse is still doable, but with a touchpad it's nearly impossible on a big screen.
thanks.

Comment 2

a year ago
Agree with Michal's observation above. Note also that many Firefox users choose just this browser due to its high degree of customisability - moving the sidebar from one side to another by <i>fiat</i> would seem to violate this principle. It would have been best if an option had been added to allow users to move the sidebar from its customary position on the left of the FF window to the right if they so desired ; now that it has been moved, I hope an option will be provided to allow those of us who wish to do so to move it back....

Many thanks

Henri
Component: General → Toolbars and Customization
OK I posted this elsewhere but there are many add-ons to toggle sidebars between left and right side.  Unfortunately they all really toggle between on the right and default position, so they do not help you much after the default position became the right hand side.

So the one I chose which will not work after version 57 when such add-ons will be barred.  but anyway if you install sideboard you can set it to be ont he left and not be docked and to auto-hide.  That is my preferred behavior.  I think if the idea is to make things better rather than just different with the new default theme then trying to get this behavior into the core behavior is what is required.  you could before this brain damaged move to right patch landed pick which side and have it undocked on either side and if undocked select auto-hide.  SO my behavior I love is on the leave as is  and allow-hidden and switching sides.  I really think we need to integrate what this add-on provided into the base product.
This will be handled in Bug 1355331
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1355331
You need to log in before you can comment on or make changes to this bug.