uninterruptible reflow at attach/<@resource:///modules/ExtensionPopups.jsm:481:7

RESOLVED WONTFIX

Status

enhancement
RESOLVED WONTFIX
2 years ago
Last year

People

(Reporter: florian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf])

Here's the stack:

attach/<@resource:///modules/ExtensionPopups.jsm:481:7
TaskImpl_run@resource://gre/modules/Task.jsm:319:42
The sync reflows is caused at http://searchfox.org/mozilla-central/rev/f225dbcb15ca2e38f7d434a9278a41d2340e7cf3/browser/components/extensions/ExtensionPopups.jsm#481 by

      // Store the initial height of the view, so that we never resize menu panel
      // sub-views smaller than the initial height of the menu.
      this.viewHeight = this.viewNode.boxObject.height;

But there's also a getBoundingClientRect call 3 lines later.
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit
We need this geometry information at this point, so there's not much we can do to fix this.

In any case, this UI is going away in photon, so the problem will go away on its own soon enough.
Status: NEW → RESOLVED
Closed: 2 years ago
Component: WebExtensions: General → WebExtensions: Frontend
Depends on: 1354109
Resolution: --- → WONTFIX
No longer blocks: photon-performance-triage
Priority: P3 → --
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf]
(In reply to Kris Maglione [:kmag] from comment #2)
> We need this geometry information at this point, so there's not much we can
> do to fix this.
> 
> In any case, this UI is going away in photon, so the problem will go away on
> its own soon enough.

Wouldn't we have the same problem with the overflow menu?
Flags: needinfo?(kmaglione+bmo)
The overflow menu can shrink when we show the panel, so we won't need geometry information at that point after we move out of the panelUI menu.
Flags: needinfo?(kmaglione+bmo)
Duplicate of this bug: 1363265
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.