Closed Bug 1359228 Opened 4 years ago Closed 4 years ago

Crash in mozilla::layers::CrossProcessSemaphoreReadLock::CrossProcessSemaphoreReadLock

Categories

(Core :: Graphics: Layers, defect)

54 Branch
x86
Windows
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1341496
Tracking Status
firefox-esr45 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 + fixed
firefox55 --- fixed

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-470ea5d2-f0b4-4737-84dd-3e94a0170424.
=============================================================
Crashing Thread (25)
Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::layers::CrossProcessSemaphoreReadLock::CrossProcessSemaphoreReadLock(void*) 	gfx/layers/client/TextureClient.cpp:1455
1 	xul.dll 	mozilla::MakeAndAddRef<mozilla::layers::CrossProcessSemaphoreReadLock, void* const&>(void* const&) 	obj-firefox/dist/include/mozilla/RefPtr.h:645
2 	xul.dll 	mozilla::layers::TextureReadLock::Deserialize(mozilla::layers::ReadLockDescriptor const&, mozilla::layers::ISurfaceAllocator*) 	gfx/layers/client/TextureClient.cpp:1510
3 	xul.dll 	mozilla::layers::CompositableParentManager::AddReadLocks(nsTArray<mozilla::layers::ReadLockInit>&&) 	gfx/layers/ipc/CompositableTransactionParent.cpp:294
4 	xul.dll 	mozilla::layers::LayerTransactionParent::RecvInitReadLocks(nsTArray<mozilla::layers::ReadLockInit>&&) 	gfx/layers/ipc/LayerTransactionParent.cpp:138
5 	xul.dll 	mozilla::layers::PLayerTransactionParent::OnMessageReceived(IPC::Message const&) 	obj-firefox/ipc/ipdl/PLayerTransactionParent.cpp:103
6 	xul.dll 	mozilla::layers::PCompositorBridgeParent::OnMessageReceived(IPC::Message const&) 	obj-firefox/ipc/ipdl/PCompositorBridgeParent.cpp:561
7 	xul.dll 	mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const&) 	ipc/glue/MessageChannel.cpp:1812
8 	xul.dll 	mozilla::ipc::MessageChannel::DispatchMessageW(IPC::Message&&) 	ipc/glue/MessageChannel.cpp:1747
9 	xul.dll 	mozilla::ipc::MessageChannel::RunMessage(mozilla::ipc::MessageChannel::MessageTask&) 	ipc/glue/MessageChannel.cpp:1620
10 	xul.dll 	mozilla::ipc::MessageChannel::MessageTask::Run() 	ipc/glue/MessageChannel.cpp:1653
11 	xul.dll 	MessageLoop::RunTask(already_AddRefed<mozilla::Runnable>) 	ipc/chromium/src/base/message_loop.cc:358
12 	xul.dll 	MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask&&) 	ipc/chromium/src/base/message_loop.cc:366
13 	xul.dll 	MessageLoop::DoWork() 	ipc/chromium/src/base/message_loop.cc:441
14 	xul.dll 	base::MessagePumpForUI::DoRunLoop() 	ipc/chromium/src/base/message_pump_win.cc:212
15 	xul.dll 	base::MessagePumpWin::RunWithDispatcher(base::MessagePump::Delegate*, base::MessagePumpWin::Dispatcher*) 	ipc/chromium/src/base/message_pump_win.cc:56
16 	xul.dll 	base::MessagePumpWin::Run(base::MessagePump::Delegate*) 	ipc/chromium/src/base/message_pump_win.h:80
17 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc:231
18 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc:211
19 	xul.dll 	base::Thread::ThreadMain() 	ipc/chromium/src/base/thread.cc:179
20 	xul.dll 	`anonymous namespace'::ThreadFunc 	ipc/chromium/src/base/platform_thread_win.cc:28
21 	kernel32.dll 	BaseThreadInitThunk 	
22 	ntdll.dll 	__RtlUserThreadStart 	
23 	ntdll.dll 	_RtlUserThreadStart

this crash signature is new in firefox 54 - so far it's rather low-volume though.
Hi Peter,
Can you help shed some light here?
Flags: needinfo?(howareyou322)
[Tracking Requested - why for this release]: This is a fairly low volume crash, but the last week it has 77 crashes in 13 installations, so fairly important for the people whom it affects.
Track 54+ so that we won't miss this crash.
Kevin, please help to look at this issue.
Flags: needinfo?(howareyou322) → needinfo?(kechen)
(In reply to Nathan Froyd [:froydnj] from comment #2)
> [Tracking Requested - why for this release]: This is a fairly low volume
> crash, but the last week it has 77 crashes in 13 installations, so fairly
> important for the people whom it affects.

In my guess, the low volume starting from the last weed should be the patch of bug 1341496 landed into beta.
Please see [1] for details.


[1]: https://bugzilla.mozilla.org/show_bug.cgi?id=1341496#c21
(In reply to Vincent Liu[:vliu] from comment #5)
> (In reply to Nathan Froyd [:froydnj] from comment #2)
> > [Tracking Requested - why for this release]: This is a fairly low volume
> > crash, but the last week it has 77 crashes in 13 installations, so fairly
> > important for the people whom it affects.
> 
> In my guess, the low volume starting from the last weed should be the patch
> of bug 1341496 landed into beta.
> Please see [1] for details.
> 
> 
> [1]: https://bugzilla.mozilla.org/show_bug.cgi?id=1341496#c21

Sorry about not clearly for my statements. From tracked into the code, I found that this issue should be fixed after the patches of bug 1341496 uplift to beta(on 4/26). The crash rate dropped starting from Apr. 26 also indicate that the patches works. I will set it as dup of 1341496 to resolve. Reopen it if anyone doesn't agree with it.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1341496
Clear ni based on comment 6.
Flags: needinfo?(kechen)
You need to log in before you can comment on or make changes to this bug.