The icons of the the default top sites are oversized when starting Fennec in landscape (iPhone 6/7 Plus)

RESOLVED FIXED

Status

()

Firefox for iOS
Home screen
P1
normal
RESOLVED FIXED
8 months ago
5 months ago

People

(Reporter: csuciu, Assigned: farhan)

Tracking

({reproducible})

unspecified
Other
iOS
reproducible

Firefox Tracking Flags

(fxios8.0+, fxios-v8.0 affected)

Details

(Whiteboard: [mobileAS])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 months ago
master f9f4cf1ba
iPhone 6 Plus (10.3)

1. Place the device in landscape.
2. Install Firefox via Xcode. 
3. "Start Browsing" in First Run Tour.
4. Check the top sites in landscape.

Result: http://imgur.com/W2NINTD

5. Switch to portrait.

Result: http://imgur.com/a/Reier
tracking-fxios: ? → 8.0+
Priority: -- → P2
(Assignee)

Updated

8 months ago
Whiteboard: [mobileAS]
(Assignee)

Comment 1

8 months ago
I cant seem to reproduce this on master ec47141
is this still happening, I tried this on both a iphone 6 and 6plus simulator.
Flags: needinfo?(catalin.suciu)
(Reporter)

Comment 2

8 months ago
'WORKSFORME' on master d9c3ccb68
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(catalin.suciu)
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

7 months ago
I'm able to reproduce this issue on master bcd93f1319/iPhone 6 Plus (10.3.2) using the STR's from the description.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Reproducible on my iPhone 7+
Keywords: reproducible
(Assignee)

Comment 5

7 months ago
Created attachment 8871027 [details] [review]
Pull Request

Catalin can you try this PR on your device if you get the chance. Im sure this will fix it but I cant replicate this in the simulator.
Attachment #8871027 - Flags: feedback?(catalin.suciu)
(Assignee)

Updated

7 months ago
Assignee: nobody → fpatel
Iteration: --- → 1.22
Priority: P2 → P1
(Reporter)

Comment 6

7 months ago
Created attachment 8871248 [details]
Screen Shot 2017-05-25 at 15.04.22.png

I've tried the patch and I'm still able to reproduce. Also I was able to reproduce in the simulator (see the attached screenshot).

Updated

7 months ago
Iteration: 1.22 → 1.23
(Assignee)

Comment 7

6 months ago
Do you have some more steps I can use for the Simulator. I cant reproduce this on the same iphone 6 plus simulator.
Flags: needinfo?(catalin.suciu)

Updated

6 months ago
Iteration: 1.23 → 1.24

Updated

6 months ago
Iteration: 1.24 → 1.25
(Assignee)

Comment 8

5 months ago
Simon and I were not able to replicate this on master 24ca2db
Status: REOPENED → RESOLVED
Last Resolved: 8 months ago5 months ago
Flags: needinfo?(catalin.suciu)
Resolution: --- → FIXED

Updated

5 months ago
Attachment #8883698 - Flags: review?(jhugman)
Oops I added my patch to the wrong bug.

Updated

5 months ago
Attachment #8883698 - Attachment is obsolete: true
Attachment #8883698 - Flags: review?(jhugman)
(Reporter)

Updated

5 months ago
Attachment #8871027 - Flags: feedback?(catalin.suciu)
You need to log in before you can comment on or make changes to this bug.