Back button paint times significantly worse in Firefox

RESOLVED DUPLICATE of bug 1362625

Status

()

defect
RESOLVED DUPLICATE of bug 1362625
2 years ago
2 years ago

People

(Reporter: benjamin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qf:p1])

Reporter

Description

2 years ago
This bug is based off video recording performance data that I took last week.

STR:
* Load https://www.amazon.com
* type "lord of the rings" into the search box
* scroll down some to skip advertisements and show several product listings
* click the first non-advertisement result, which should be a product listing for the instant video LOTR.
* click the back button

MEASURED:
* start at mouseup on the back button
* Time A (firstpaint): first frame of anything nonblank from the search listing page
* Time B (hero content): first frame where the search listing page is scrolled to the correct position and the thumbnails of the search results are painted

PERFORMANCE DIFFERENCE:
Time A:
chrome averages 11 frames/179ms
FF averages 26 frames/438 ms
Firefox is 144% slower than Chrome

Time B:
chrome averages 17 frames/275ms
Firefox averages 26 frames/438 ms
Firefox is 59% slower than Chrome

Note that the Firefox first paint is always the complete content in the correct position, so time A and time B are identical.

Chrome appears to re-layout the page and in fact at first paint the page is in the incorrect scroll position.

My ask here is to focus on diagnosing time B and making it at least as fast as Chrome, but if there are opportunities to paint something sooner that would help give users additional feedback that Firefox was doing something.

Naveed please let me know if there's a more appropriate component or whether we should leave this in untriaged until we have profiles/diagnosis of next steps.
Reporter

Updated

2 years ago
Flags: needinfo?(nihsanullah)
Flags: needinfo?(nihsanullah)
Whiteboard: [qf] → [qf:p1]

Comment 1

2 years ago
This is one of the bugs of the top 5 sites that requires profiling...
Flags: needinfo?(ryanvm)
Flags: needinfo?(ryanvm) → needinfo?(afilip)

Comment 2

2 years ago
I ended up profiling it myself and filing bug 1362625.  I couldn't find this bug thanks to Bugzilla's search when I was looking for it.  :P
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1362625

Updated

2 years ago
Flags: needinfo?(afilip)
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.