Remove e10s-multi beta experiment 2 and 8 process count cohorts and separate addon / no addon users in remaining buckets

RESOLVED FIXED in Firefox 54

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jimm, Assigned: mrbkap)

Tracking

Trunk
Firefox 55
Points:
---

Firefox Tracking Flags

(firefox54 fixed, firefox55 fixed)

Details

Attachments

(3 attachments)

Reporter

Description

2 years ago
Todo for the current system add-on:

1) remove cohorts for 2 and 8 content process, keep 1 and 4 content process cohorts

2) lets try to split up extension / no extension users into separate cohorts for the two remaining buckets
Flags: needinfo?(mrbkap)
Reporter

Updated

2 years ago
Summary: Strip e10s-multi beta experiment 2 and 8 process count buckets and separate addon / no addon users in remaining buckets → Remove e10s-multi beta experiment 2 and 8 process count cohorts and separate addon / no addon users in remaining buckets
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee: nobody → mrbkap
Flags: needinfo?(mrbkap)

Comment 4

2 years ago
mozreview-review
Comment on attachment 8861606 [details]
Bug 1359495 - Don't put disqualified users in multi buckets to fix cohort naming confusion.

https://reviewboard.mozilla.org/r/133570/#review136454
Attachment #8861606 - Flags: review?(felipc) → review+

Comment 5

2 years ago
mozreview-review
Comment on attachment 8861607 [details]
Bug 1359495 - Expose webextension status in the multi cohorts.

https://reviewboard.mozilla.org/r/133572/#review136456

Nice trick!
Attachment #8861607 - Flags: review?(felipc) → review+

Comment 6

2 years ago
mozreview-review
Comment on attachment 8861608 [details]
Bug 1359495 - Change the process scheme to better test what we intend on releasing.

https://reviewboard.mozilla.org/r/133574/#review136458

Two nits that I was gonna ask you to do in another bug before seeing this one. But since it's touching the files here, might as well do it here:

- what you think of changing the variable name inMultiExperiment to eligibleForMulti?  I think it will make the code a bit more self explanatory?
- please bump the version number e10srollout/install.rdf to 1.50. I forgot to ask about it in the original bug, but it's fine to do here. I want to have a gap from the current version number so that it's easier to differentiate.

::: browser/extensions/e10srollout/bootstrap.js:24
(Diff revision 1)
> +  "beta": {
> +    1: .5,
> +    4: 1,
> +  },

uber nit: put the inner obj here in one line to make it one-liners to change these or add more channels.

(I realize eslint might not be happy about it, so if eslint complains about it just ignore it. But I think it allows one-line objects.

::: browser/extensions/e10srollout/bootstrap.js:178
(Diff revision 1)
>    // - If the user already opted into multi, then their prefs are already set
>    //   correctly, we're done.
>    // - If the user has addons that disqualify them for multi, leave them with
>    //   the default number of content processes (1 on beta) but still in the
>    //   test cohort.
> -  if (updateChannel !== "beta" ||
> +  if ((updateChannel in MULTI_BUCKETS) ||

This should be a negative
Attachment #8861608 - Flags: review?(felipc) → review+
Comment hidden (mozreview-request)
Comment on attachment 8861606 [details]
Bug 1359495 - Don't put disqualified users in multi buckets to fix cohort naming confusion.

Approval Request Comment
[Feature/Bug causing the regression]: e10s-multi experiment
[Needs manual test from QE? If yes, steps to reproduce]: 
[Is the change risky?]: No, low risk. These changes are well-understood.
[Why is the change risky/not risky?]:
[String changes made/needed]:
Attachment #8861606 - Flags: approval-mozilla-beta?

Comment 9

2 years ago
Pushed by mrbkap@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/271acc9d32e5
Don't put disqualified users in multi buckets to fix cohort naming confusion. r=Felipe
https://hg.mozilla.org/integration/autoland/rev/d83907ea33ab
Expose webextension status in the multi cohorts. r=Felipe
https://hg.mozilla.org/integration/autoland/rev/35e9b30a0497
Change the process scheme to better test what we intend on releasing. r=Felipe
Comment on attachment 8861606 [details]
Bug 1359495 - Don't put disqualified users in multi buckets to fix cohort naming confusion.

Support for e10s-multi experiment. Beta54+. Should be in 54 beta 3.
Attachment #8861606 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.