Wish: Add an Exchange provider as core component of Lightning

RESOLVED WONTFIX

Status

Calendar
General
RESOLVED WONTFIX
7 months ago
6 months ago

People

(Reporter: Frank Thommen, Unassigned)

Tracking

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20170308163539

Steps to reproduce:

One big problem with Lightning is, that it can't talk to Exchange, which makes it unattractive in companies and organizations with Exchange-based mail and calendar,  The only alternative known to me is the Exchange EWS Provider (https://github.com/Ericsson/exchangecalendar) which currently has a huge problem (https://github.com/Ericsson/exchangecalendar/issues/580) which no one seems to be able or willing to fix.

Could an Exchange Provider be made a core component of Lightning?  This would finally make TB an email and calendar client for all those who (have to) work in an Exchange dominated environment

Comment 1

7 months ago
The last commit in the repository is from August, 3 2016 and nearly all commits since some time in 2014 have been from a single person. So the addon looks to be kind of abandoned atm.

The Lightning team consists of volunteers only and is already short at resources/time, so apart from a licencing issue (the code would need to be re-licensed under MPL2), personally I would be reluctant to upstream a large extension like this in the current situation without getting additional contributors on board sufficient to maintain the additional code (at already knwo it), although I recognize, that it would be a loss of not having a working option for a native exchange access around (especially, since the only available alternative of using DavMail as an intermediate has some flaws from time to time). And based on the date of the last commit and given to our changes for event-in-a-tab, I would expect there's more work to do to catch up to Lightning 5.4 and newer than the issue mentioned above.

As connecting to an Exchange server is typically a feature needed by business users, you and other interested users might consider to found the extension (with or without upstreaming) appropriately to close the gap and keep up with ongoing changes in Thunderbird/Lightning including the upcoming TB rewrite and find one or more new capable maintainer for it. We can try to help with the latter.

Philipp any other of the Lightning team - any comments? Or maybe Kent?
I agree that we shouldn't be adding new add-ons to core unless we can handle the maintenance and there is an active team developing it. For Providers, the whole idea is to have them as add-ons. I could imagine making it easier to get more providers, e.g. by having a get more link that opens the right category in the add-ons manager, but I don't think we should import the Exchange Provider.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

7 months ago
(In reply to [:MakeMyDay] from comment #1)
> The last commit in the repository is from August, 3 2016 and nearly all
> commits since some time in 2014 have been from a single person. So the addon
> looks to be kind of abandoned atm.

The latest release (3.9.0) is from January 12th, 2017, and it worked perfectly until TB upgraded to 52 w. Lightning 5.4

> [...]
> 
> As connecting to an Exchange server is typically a feature needed by
> business users,

I cannot confirm that, as I've never worked in a "business" environment.  The environments where I encountered Exchange based mail and calendar systems were a university (10'000 employees) and a research facility (5000 employees).  So from my experience this is not an issue only of "business" environments, but also of big academic environments.  The usual workaround is to use Windows/Outlook or Exchange Webmail :-(

> you and other interested users might consider to found the
> extension (with or without upstreaming) appropriately to close the gap and
> keep up with ongoing changes in Thunderbird/Lightning including the upcoming
> TB rewrite and find one or more new capable maintainer for it. We can try to
> help with the latter.

I cannot help with programming at all, sorry.  I wrote this wish from the perspective of the "user only" that I am.  My proposition was not to "adopt" the currently existing "Exchange EWS Provider" plugin but to develop this functionality as a core component of Lightning on your own.  However as I understand Philipp Kewisch's comment, this would conflict with the Lightning team's current policy on how to handle providers.  And of course I also completely understand the personnel situation of the Lightning team.  But following https://github.com/Ericsson/exchangecalendar/issues/580 it seems, that there is currently no one with enough knowhow and time to take over the further development of this plugin.  That's a pity, but maybe we finally /will/ have to switch to webmail or Windows/Outlook.

Comment 4

6 months ago
https://github.com/Ericsson/exchangecalendar/issues/580
with 3.9.0y sent by rkent and commenting the if() block work well now.
15 days to get a fix.
You need to log in before you can comment on or make changes to this bug.