13.86ms uninterruptible reflow at close@chrome://browser/content/browser-fullScreenAndPointerLock.js:133:5

RESOLVED FIXED in Firefox 55

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: marco, Unassigned)

Tracking

(Blocks 2 bugs)

unspecified
Firefox 55
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p2][reserve-photon-performance])

Reporter

Description

2 years ago
Here's the stack:

close@chrome://browser/content/browser-fullScreenAndPointerLock.js:133:5
cleanupDomFullscreen@chrome://browser/content/browser-fullScreenAndPointerLock.js:469:5
handleEvent@chrome://browser/content/browser-fullScreenAndPointerLock.js:372:9
EventListener.handleEvent*init@chrome://browser/content/browser-fullScreenAndPointerLock.js:259:5
_delayedStartup@chrome://browser/content/browser.js:1506:5
EventListener.handleEvent*onLoad@chrome://browser/content/browser.js:1239:5
onload@chrome://browser/content/browser.xul:1:1
Component: Untriaged → General
Depends on: 1356034
That line is:     gBrowser.selectedBrowser.focus();
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p1][photon-performance]
Flags: qe-verify? → qe-verify-
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p1][photon-performance] → [ohnoreflow][qf:p1][reserve-photon-performance]
Whiteboard: [ohnoreflow][qf:p1][reserve-photon-performance] → [ohnoreflow][qf:p2][reserve-photon-performance]
I can no longer reproduce a reflow in this codepath since bug 1369140 landed.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Iteration: --- → 55.7 - Jun 12
Priority: P3 → P1
You need to log in before you can comment on or make changes to this bug.