Closed Bug 1359824 Opened 4 years ago Closed 4 years ago

Multiprocess compatible error displayed for Themes and Plugins in Add-ons Manager

Categories

(Toolkit :: Add-ons Manager, defect, P1)

55 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla55
Tracking Status
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- verified

People

(Reporter: vtamas, Assigned: aswan)

Details

Attachments

(2 files)

Attached file mpcerror.zip
[Affected versions]:
Firefox 55.0a1 (2017-04-26)


[Affected platforms]:
Windows 10 64-bit
Ubuntu 14.04 64-bit

[Steps to reproduce]:
1.Launch Firefox with a clean profile.
2.Navigate to about:addons -> Appearance/Plugins


[Expected Results]:
There is no error displayed for themes and plugins in Add-ons Manager.


[Actual Results]:
- “[Name] has been disabled since it is not multiprocess compatible” error appears for all themes and plugins installed and the “Enable”/”Disable” buttons are still displayed.
- See attached screenshots.
No longer blocks: 1352204
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1359476
I’m not sure this is a dupe of Bug 1359476 because themes and plugins are not actually disabled and they can still be installed. The only issue here is that mpc error message is displayed. While the dictionaries and lang packs are entirely disabled and their installation is blocked.
Flags: needinfo?(aswan)
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #2)
> I’m not sure this is a dupe of Bug 1359476 because themes and plugins are
> not actually disabled and they can still be installed. The only issue here
> is that mpc error message is displayed. While the dictionaries and lang
> packs are entirely disabled and their installation is blocked.

whoops, you're right, thanks.
Assignee: nobody → aswan
Flags: needinfo?(aswan)
Priority: -- → P1
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attachment #8862072 - Flags: review?(dtownsend)
Comment on attachment 8862072 [details]
Bug 1359824 Only display error for disabled addons

https://reviewboard.mozilla.org/r/134036/#review136988
Attachment #8862072 - Flags: review?(dtownsend) → review+
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/175439e20aa5
Only display error for disabled addons r=mossop
https://hg.mozilla.org/mozilla-central/rev/175439e20aa5
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Confirm that multiprocess error is no longer displayed for themes, plugins, dictionaries and lang packs on Firefox 55.0a1 (2017-04-28) and test builds from https://bugzilla.mozilla.org/show_bug.cgi?id=1352204#c27 under Windows 10 64-bit, Ubuntu 14.04 64-bit and Mac OS X 10.12.1. See screenshot: https://www.screencast.com/t/NV1Ftmf7cC
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.