Disable animations entirely on really low-speced hardware?

RESOLVED DUPLICATE of bug 1351413

Status

()

Firefox
General
P5
normal
RESOLVED DUPLICATE of bug 1351413
a year ago
10 months ago

People

(Reporter: wlach, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Seeing bug 1352069 reminded me of something. When I sped up the tab animations a few months back (bug 1302727) I tested how they looked on a really underspecced laptop that :mconley had:

https://bugzilla.mozilla.org/show_bug.cgi?id=1302727#c34

Here's what it looked like:

https://drive.google.com/open?id=0B1JDLRVWauyebFVxR3QwQ3dKT3M

tl;dr there is almost no animation visible -- if you look closely you see one intermediate state which (to my eye) is only perceivable as jank. Doing nothing would almost be better than what we're seeing there. Is there any way we could detect really underpowered machines and flip the pref in bug 1352069 (or produce equivalent behaviour)?

I'm going to mark this as blocking photon-animation but feel free to undo that. Or just mark this as wontfix if I'm way off base. :jaws, as the person who filed bug 1352069, what do you think?
Flags: needinfo?(jaws)
I believe this will be implemented as part of https://bugzilla.mozilla.org/show_bug.cgi?id=1357316. Evan, is this a dupe?
Blocks: 1357316
Flags: needinfo?(jaws) → needinfo?(evan)
Hi Jared,

Honestly, I'm not sure about that. As my understand, the Optimize Firefox feature is still on planning/designing stage and we don't have clear enough idea for that. But I would say this is a good idea, it's a part of Optimize Firefox feature. Let's needinfo our product manager (Cindy) to tell more detail.

Hi Cindy,

Do you think this bug is included in the Optimize Firefox scope?

Thanks.
Flags: needinfo?(evan) → needinfo?(chsiang)

Comment 3

a year ago
Optimize Firefox button behavior is still under discussion. We should not consider it in the scope at this point unless we can- pull off a quick testing, have a positive result back, and are able to implement the behavior quickly after evaluation.
Flags: needinfo?(chsiang)
Maybe related to bug 1357349?
Depends on: 1357349
Priority: -- → P5

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1351413
You need to log in before you can comment on or make changes to this bug.