1.13ms uninterruptible reflow at PopupNotifications_dismiss@resource://gre/modules/PopupNotifications.jsm:690:7

RESOLVED FIXED in Firefox 55

Status

()

Firefox
General
P1
normal
RESOLVED FIXED
6 months ago
5 months ago

People

(Reporter: mconley, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 55
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p2][reserve-photon-performance])

Here's the stack:

PopupNotifications_dismiss@resource://gre/modules/PopupNotifications.jsm:690:7
PopupNotifications_update@resource://gre/modules/PopupNotifications.jsm:1112:9
anchorVisibilityChange@resource://gre/modules/PopupNotifications.jsm:579:7
UpdatePopupNotificationsVisibility@chrome://browser/content/browser.js:2740:3
SetPageProxyState@chrome://browser/content/browser.js:2727:3
URLBarSetURI@chrome://browser/content/browser.js:2594:3
onLocationChange@chrome://browser/content/browser.js:4698:7
callListeners@chrome://browser/content/tabbrowser.xml:492:24
_callProgressListeners@chrome://browser/content/tabbrowser.xml:507:13
updateCurrentBrowser@chrome://browser/content/tabbrowser.xml:1145:13
onselect@chrome://browser/content/browser.xul:1:44
set_selectedIndex@chrome://browser/content/tabbrowser.xml:7773:13
set_selectedPanel@chrome://global/content/bindings/tabbox.xml:691:13
set_selectedIndex@chrome://global/content/bindings/tabbox.xml:409:15
set_selectedItem@chrome://global/content/bindings/tabbox.xml:441:34
set_selectedTab@chrome://global/content/bindings/tabbox.xml:111:15
set_selectedTab@chrome://browser/content/tabbrowser.xml:3402:11
getAPI/create/<@chrome://browser/content/ext-tabs.js:371:15

Updated

6 months ago
Flags: qe-verify?
Priority: -- → P2
Duplicate of this bug: 1360150

Updated

6 months ago
Depends on: 1356034

Updated

6 months ago
Component: Untriaged → General
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p1][photon-performance]

Updated

5 months ago
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p1][photon-performance] → [ohnoreflow][qf:p1][reserve-photon-performance]

Updated

5 months ago
Flags: qe-verify? → qe-verify-
Whiteboard: [ohnoreflow][qf:p1][reserve-photon-performance] → [ohnoreflow][qf:p2][reserve-photon-performance]
I can no longer reproduce a reflow in this codepath since bug 1369140 landed.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55

Updated

5 months ago
Iteration: --- → 55.7 - Jun 12
Priority: P3 → P1
You need to log in before you can comment on or make changes to this bug.