detail is not visible for bare json strings in response viewer

RESOLVED FIXED in Firefox 57

Status

P2
normal
RESOLVED FIXED
2 years ago
6 months ago

People

(Reporter: echo, Assigned: dex, Mentored)

Tracking

54 Branch
Firefox 57

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 wontfix, firefox55 wontfix, firefox56 wontfix, firefox57 fixed)

Details

(Whiteboard: good-first-bug)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170418123106

Steps to reproduce:

1. Open the developer tools.
2. Make a request that returns content-type application/json and has a body of a quoted string by itself. I've put this up for testing: https://jc6e81at9k.execute-api.us-west-2.amazonaws.com/dev/jsonstring
3. Click on the network tab, then the request you just made, then the response tab.


Actual results:

It's blank, showing only the word "JSON" that always appears at the top.


Expected results:

It should show the string returned. A bare quoted string is perfectly valid JSON. JSON.stringify will produce one, and JSON.parse will accept one.

(I reported this against 54, but it's not actually new.)
Component: Untriaged → Developer Tools: Netmonitor

Comment 1

a year ago
It exists but is almost invisible because it is almost white:
color: rgb(245, 247, 250);

tree-view.css:79
.treeTable .treeRow.selected:not(:hover) *
var(--theme-selection-color)


If set devtools use dark theme, it is visible.
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All

Comment 2

a year ago
(In reply to YF (Yang) from comment #1)
> It exists but is almost invisible because it is almost white:
> color: rgb(245, 247, 250);
> 
> tree-view.css:79
> .treeTable .treeRow.selected:not(:hover) *
> var(--theme-selection-color)
> 
> 
> If set devtools use dark theme, it is visible.

Seem not for Firefox 54, white text for Fx55 and Nightly 56.
status-firefox54: --- → affected
status-firefox55: --- → affected
status-firefox56: --- → affected
status-firefox-esr52: --- → unaffected
Summary: Netmonitor's JSON viewer breaks on bare strings → detail is not visible for bare json strings in response viewer
Mentor: odvarko
Priority: -- → P2
Whiteboard: good-first-bug
(Assignee)

Comment 3

a year ago
Hi, I would like to work on this one.
Comment hidden (mozreview-request)
Assignee: nobody → dex
Comment on attachment 8899199 [details]
Bug 1360082 - Network monitor: use devtools theme alt color for bare json strings in response viewer

https://reviewboard.mozilla.org/r/170470/#review177412

Works for me, thanks for the patch!

Honza
Attachment #8899199 - Flags: review?(odvarko) → review+

Comment 6

a year ago
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bfce5393f345
Network monitor: use devtools theme alt color for bare json strings in response viewer r=Honza

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/bfce5393f345
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
We probably want this to ride the train.
status-firefox54: affected → wontfix
status-firefox55: affected → wontfix
status-firefox56: affected → wontfix

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.