Closed Bug 1360434 Opened 3 years ago Closed 3 months ago

Serializing and deserializing SharedArrayBuffer (inc. BroadcastChannel support)

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1610020

People

(Reporter: annevk, Unassigned)

References

(Blocks 2 open bugs)

Details

For issues not covered by bug 1359017, bug 1359745, and bug 1360190. Tests are in web-platform-tests:

  html/infrastructure/safe-passing-of-structured-data/shared-array-buffers/

Online version (times out at times, not sure what's up): https://w3c-test.org/html/infrastructure/safe-passing-of-structured-data/shared-array-buffers/

Change to the standard which will land later today: https://github.com/whatwg/html/pull/2518

Once it lands, it's part of https://html.spec.whatwg.org/multipage/infrastructure.html#safe-passing-of-structured-data
Priority: -- → P3
Blocks: resab
Summary: Serializing and deserializing SharedArrayBuffer → Serializing and deserializing SharedArrayBuffer (inc. BroadcastChannel support)
Component: DOM → DOM: Core & HTML
Blocks: 1563480
No longer blocks: resab
Blocks: 1589673
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1610020
You need to log in before you can comment on or make changes to this bug.