Web Apps - snapdrop.net cannot be installed as pwa on Huawei/Xiaomi devices

RESOLVED INVALID

Status

()

Firefox for Android
Web Apps
P2
normal
RESOLVED INVALID
a year ago
7 months ago

People

(Reporter: Oana Horvath, Unassigned)

Tracking

(Blocks: 1 bug)

55 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8862739 [details]
logcat.txt

Devices:
-Huawei Honor 5X (Android 5.1.1)
-Xiaomi Mi Pad 2 - Android 5.1

Build: Nightly 55.0a1 (2017-04-27);

Steps to reproduce:
1. Go to snapdrop.net.
2. Add page to the home screen (turn manifest.install.enabled preference "true")

Expected result:
A web app is installed.

Actual result:
Nothing happens. There is no error/message displayed, nor a shortcut created.

Notes:
Only reproducible on my Huawei and Xiamoi devices, with this web page. On others, it works well.
(Reporter)

Updated

a year ago
Blocks: 1285858
Assignee: nobody → dale
Wesley, is there anyone in Tapei familiar with Android that has these devices on hand that could steal this from me? I cant reproduce this on emulators and dont have spare androids on hand. I suspect it will not take long to fix once the issue is identified.

Oana, is this still happening? if so could you give us a copy of adb logcat from the moment you press "Add to Home Screen" onwards

Thanks
Flags: needinfo?(whuang)
Flags: needinfo?(oana.horvath)
(Reporter)

Comment 2

a year ago
Created attachment 8864865 [details]
log5-5-2017.txt

Yes, still happening. Attached log from Nightly 5/5/2017.
Flags: needinfo?(oana.horvath)
Thats great thanks

> 05-05 16:15:56.418: E/GeckoBrowserApp(29178): Failed to load icon!

So the issue is the image seems to be loaded fine inside gecko and fails to transfer to java nicely, this should be fairly trivial for anyone that can reproduce to fix
AFAIK we don't have these Xiaomi/Huawei devices handy.
But we can try it with another device running android5.

Comment 5

a year ago
Can't reproduce the issue on Sony Z3C(5.0.2)
Don't have 5.1 devices here. Tried on 5.1 emulators (with or without Google APIs) to no avail.
Gonna deassign myself until I can get this reproduced

Oana if possible do you have either Huawei, Xiaomi on more recent androids to test? Also what type of Android is on those devices, is it stock android, touchwiz etc? Thanks
Flags: needinfo?(whuang) → needinfo?(oana.horvath)
Assignee: dale → nobody
(Reporter)

Comment 7

a year ago
These are my devices and they all have their own Android based ROM:
Huawei MediaPad M2 with MIUI 7.0 based on Android 5.1.1.
Huawei Honor 8 with EMUI 4.1, on Android 6.0.
Huawei Honor 5X with EMUI 3.1, on Android 5.1.1.
Xiaomi Mi Pad 2, x86 architecture, with MIUI 7.0, on Android 5.1.

The most recent I have is Android 6. The issue with snapdrop.net app is reproducing on all of them.

Also, I've found that on Xiaomi Mi Pad 2 (just this one), with "Don't keep activities" on, no web app can be installed.
Flags: needinfo?(oana.horvath)

Updated

11 months ago
Assignee: nobody → dale
Assignee: dale → nobody
Priority: -- → P2
Snapdrop.net is down at the moment.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.