Closed Bug 1360481 Opened 3 years ago Closed 2 years ago

Variable GPOS mark positions not working correctly

Categories

(Core :: Layout: Text and Fonts, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1360128

People

(Reporter: drott, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.81 Safari/537.36

Steps to reproduce:

This reftest using an additional axis VM2B in the variabletest_box
font fails to work in WebKit nightly r215833. However, the *_expected.html file renders correctly. 

The VM2B axis of this font shifts the mark anchor to the left, leading to the
combining mark SQUARE BELOW shifting right when the axis parameter is
adjusted from 0 to 1000. As the reference in the ref test, the font also
contains two additional glyphs N and O, which have fixed base anchors at
the middle and right position. A rendering of the M character showing
"m2b pos", followed by COMBINING SQUARE BELOW with VM2B 0, 500, 1000
applied must thus be equal to renderings of the N and O glyph with no
VM2B variation values applied.

Probably blocking: 1302685


Actual results:

Test case renders incorrectly, combining square below appears left, right, right, and appears even further out to the right in the expected.html file: right, more right and far right.


Expected results:

Combining square below should be left, centered and right in base and reference file.
Sorry, I mean to say this fails to work in FF nightly 55.0a1 (2017-04-27) (64-bit), I copied my bug description from the WebKit bug I filed.
Component: Untriaged → Layout: Text
Product: Firefox → Core
This is expected (for now), as we don't have variations hooked up to harfbuzz shaping yet; seems very much like bug 1360128.
Blocks: 1302685
See Also: → 1360128
Priority: -- → P3
The patch in bug 1360128 will also fix this.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1360128
You need to log in before you can comment on or make changes to this bug.