The animation is inconsistently displayed after changing the tabs

VERIFIED FIXED in Firefox 55

Status

()

Core
ImageLib
VERIFIED FIXED
2 months ago
2 months ago

People

(Reporter: roxana.leitan@softvision.ro, Assigned: tnikkel)

Tracking

55 Branch
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 verified)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

2 months ago
Created attachment 8862866 [details]
graphics stability.png

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID:20170428030259

[Affected versions]:
Nightly 55.0a1

[Affected platforms]:
Windows 10, Ubuntu 16.04 x64

[Steps to reproduce]:
1.Launch Nightly 55.0a1 with a new profile
2.Navigate to https://bug1110686.bmoattachments.org/attachment.cgi?id=8535538
3.Open a new tab
4.Open a new window and navigate to about:memory
5.Click "Minimize memory usage" button
6.Go to the tab with the animation (opened at step 2)

[Expected result]:
The animation should be displayed without glitches

[Actual result]:
The animation is inconsistently displayed(please see the attachment)
(Assignee)

Comment 1

2 months ago
Looks like an invalidation issue. Which is odd because I wrote code to handle this specific situation. I'll look into it.
(Assignee)

Comment 2

2 months ago
Created attachment 8864013 [details] [diff] [review]
patch

I forgot to invalidate in one place.
Assignee: nobody → tnikkel
Attachment #8864013 - Flags: review?(aosmond)
Attachment #8864013 - Flags: review?(aosmond) → review+

Comment 3

2 months ago
Pushed by tnikkel@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dda520b4ed32
Invalidate the whole animated image when the composited frame becomes valid. r=aosmond

Comment 4

2 months ago
backed this out for Assertion failure at RasterImage.cpp like https://treeherder.mozilla.org/logviewer.html#?job_id=96452645&repo=mozilla-inbound&lineNumber=1730
Flags: needinfo?(tnikkel)

Comment 5

2 months ago
Backout by ihsiao@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b1cfdc015e2f
Backed out changeset dda520b4ed32 for Assertion failure at RasterImage.cpp
(Assignee)

Comment 6

2 months ago
Turns out that bug 1361642 was making this pass on try server. We get a decode call when we are currently decoded.

Comment 7

2 months ago
Pushed by tnikkel@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/27e777d4ac38
Invalidate the whole animated image when the composited frame becomes valid. r=aosmond
(Assignee)

Updated

2 months ago
Depends on: 1361642
Flags: needinfo?(tnikkel)

Comment 8

2 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/27e777d4ac38
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
(Reporter)

Comment 9

2 months ago
Verified as fixed using the latest Nightly 55.0a1 (2017-05-08) on Ubuntu 16.04 x64 and Windows 10 x64.
Status: RESOLVED → VERIFIED
status-firefox55: fixed → verified
Depends on: 1363092
You need to log in before you can comment on or make changes to this bug.