Closed Bug 1360619 Opened 4 years ago Closed 3 years ago

Discontinue Firefox OS Product and WONTFIX all open bugs

Categories

(bugzilla.mozilla.org :: Graveyard Tasks, task)

Production
task
Not set
normal

Tracking

()

RESOLVED FIXED
Due Date:

People

(Reporter: lmandel, Assigned: dylan)

References

Details

Attachments

(1 file)

PR
44 bytes, text/x-github-pull-request
Details | Review
I think it's safe to move the Firefox OS Bugzilla product to graveyard at this point.
We can do something like the script from bug 1249196, rename the product to "Firefox OS Graveyard" and disallow bug entry.
See Also: → 1249196
Assignee: nobody → dylan
Attached file PR
I'll set r? after some testing.
Depends on: 1360675
Comment on attachment 8862941 [details] [review]
PR

Asking for f? from dkl since he originally wrote and ran this script, in case there's something else to worry about.
Attachment #8862941 - Flags: review?(rsoderberg)
Attachment #8862941 - Flags: feedback?(dkl)
Comment on attachment 8862941 [details] [review]
PR

Looks good to me. Should not send email. I did not run it so try it out first on bugzilla-dev.

dkl
Attachment #8862941 - Flags: feedback?(dkl) → feedback+
One snag is the automation user can't set bugs that are UNCONFIRMED to RESOLVED.
Can the automation user do it in two steps, UNCONFIRMED -> NEW -> RESOLVED?
(In reply to Emma Humphries ☕️ (she/her) [:emceeaich] (UTC-8) +needinfo me from comment #6)
> Can the automation user do it in two steps, UNCONFIRMED -> NEW -> RESOLVED?

Probably not, and that would be a bad way of solving it. I'll just give the admin user more powers -- it's not possible to login as that user anyway, so no real harm.
Rather, admin user => automation user
Attachment #8862941 - Flags: review?(rsoderberg)
Component: Administration → Graveyard Tasks
To git@github.com:mozilla-bteam/bmo.git
   20938c2a5..54af7955b  master -> master
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
See Also: → 1361245
Running this on dev currently, will run on production later on pending a success on dev (which is likely)
Summary: Move Firefox OS to graveyard → Discontinue Firefox OS Product and WONTFIX all open bugs
There are a number of large attachments in FxOS which use significant disk space. Can these be removed when we graveyard these bugs?
Flags: needinfo?(dylan)
The attachments are gone. I'll WONTFIX all the bugs shortly.
Flags: needinfo?(dylan)
I'm reopening because I don't believe we have run the script to close the bugs.
Status: RESOLVED → REOPENED
Flags: needinfo?(dylan)
Resolution: FIXED → ---
Due Date: 2018-03-02
Flags: needinfo?(dylan)
This seems easy now, so let me see if I can do it.
This process continues.
More than 20,000 bugs wontfix'd.
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.