Remove the PROCESS_TEXT intent from the search activity

RESOLVED DUPLICATE of bug 1320072

Status

RESOLVED DUPLICATE of bug 1320072
2 years ago
9 months ago

People

(Reporter: mkaply, Assigned: mkaply)

Tracking

Trunk

Details

Attachments

(1 attachment)

If you highlight text today in an application on Android and then click the ... (More), you'll see a Web Search intent and a "Firefox Search" intent.

If you then click on Web Search, you'll see another "Firefox Search".

This is happening because we're setting an intent for arbitrary text selection via the PROCESS_TEXT intent.

I don't believe we should be doing this. No other browser or search app that I could find does this. They rely on the Web Search intent.

PROCESS_TEXT is more intended for actual text specific things (like maybe translation or something like that).

Comment 1

2 years ago
This also depends on how the apps advertises the selected text and how the app treats the context menu. 

I have seen apps where the context menu contained only "Firefox Search" (Google Play, select text in app description), only "Web Search" (Pocket, select text in article) and both (Gmail, Firefox, Chrome,..).

> PROCESS_TEXT is more intended for actual text specific things (like maybe translation or something like that).
I don't follow the argument that search is not text specific.

I understand the argument that "Firefox Search" can be hidden behind "Web Search".

BTW, in the current implementation the extra "android.intent.extra.PROCESS_TEXT_READONLY" is treated as string even though it is a boolean.
Sounds like this may be a release blocker for 54 and possible driver for 53.0.2 Fennec. 
Snorp, what do you think?
status-firefox53: --- → affected
status-firefox54: --- → ?
status-firefox55: --- → ?
tracking-firefox53: --- → blocking
tracking-firefox54: --- → blocking
Flags: needinfo?(snorp)
I'm on Android 7.1 and do not see a "Web Search" option. This seems to be version or device specific?
> Sounds like this may be a release blocker for 54 and possible driver for 53.0.2 Fennec. 
Snorp, what do you think?

I think we're going to back out the whole feature for now because of other issues it creates.

> I'm on Android 7.1 and do not see a "Web Search" option. This seems to be version or device specific?

What application are you highlighting text in? I see it if I highlight text in gmail and then long press.
I'm ok with backing out the feature, but we should check with Joe.
Flags: needinfo?(snorp) → needinfo?(jcheng)
> I don't follow the argument that search is not text specific.

I just don't think that's what Google intended folks to do with this, especially given Web Search.

There initial announce of this was for translate.

https://android-developers.googleblog.com/2015/10/in-app-translations-in-android.html

> BTW, in the current implementation the extra "android.intent.extra.PROCESS_TEXT_READONLY" is treated as string even though it is a boolean.

Yeah, I saw that too.
i'm not sure if it's the real root cause of the preload failure but i will leave it to engineering to figure this out.
i'm ok with backing out this feature so we can unblock our preload efforts
Flags: needinfo?(jcheng)
This is not the root of the preload failures, this is a secondary problem. I don't believe we should have added PROCESS_TEXT in the first place because it's inconsistent with every other browser. Searching goes under Web Search, not in a separate item on the menu.
Comment hidden (mozreview-request)
Marking as dupe of 1320072 which we backed out and resetting tracking flags.

When we revisit 1320072, we need to not include this piece.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: affected → ---
status-firefox54: ? → ---
status-firefox55: ? → ---
tracking-firefox53: blocking → ---
tracking-firefox54: blocking → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1320072

Updated

9 months ago
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.