Closed Bug 1360972 Opened 4 years ago Closed 4 years ago

Bookmark favicon won't be updated when favicon is altered

Categories

(Toolkit :: Places, defect)

55 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: euthanasia_waltz, Unassigned)

Details

STR:
0. Preparation
  web server:
    node.js/http-server
  favicon files:
    favicon.dc6635050bf5.ico (from https://www.mozilla.org/media/img/firefox/favicon.dc6635050bf5.ico)
    favicon32.e02854fdcf73.png (from https://developer.cdn.mozilla.net/static/img/favicon32.e02854fdcf73.png)
  html file (index.html):
    <link rel="shortcut icon" href="favicon.dc6635050bf5.ico">
1. Run http-server
2. Start firefox with fresh new profile
3. Open localhost:8080
4. Add bookmark
5. Edit the html file as <link rel="shortcut icon" href="favicon32.e02854fdcf73.png">
6. Reload

AR:
Bookmark favicon is not updated.
(since it is flickering, removing cache and redrawing icon should have been performed)

ER:
Bookmark favicon is updated and matches to tab icon.

FWIW, in case of reversed order (favicon32.e02854fdcf73.png -> favicon.dc6635050bf5.ico), bookmark favicon is updated as expected.

Another STR:
0. Preparation
  favicon files:
    favicon.dc6635050bf5.ico (from https://www.mozilla.org/media/img/firefox/favicon.dc6635050bf5.ico)
    favicon.d4f1f46b91f4.ico (from https://www.mozilla.org/media/img/favicon.d4f1f46b91f4.ico)
  html file (index.html):
    <link rel="shortcut icon" href="favicon.d4f1f46b91f4.ico">
1. Run http-server
2. Start firefox with fresh new profile
3. Open localhost:8080
4. Add bookmark
5. Edit the html file as <link rel="shortcut icon" href="favicon.dc6635050bf5.ico">
6. Reload

FWIW, in case of reversed order (favicon.dc6635050bf5.ico -> favicon.d4f1f46b91f4.ico), bookmark favicon is updated as expected.
Icons are (and have always been) cached for 7 days, and updated *after* that time if they changed (same for discarding a no more used icon).

If the favicon changes, both may be considered valid icons since 7 days didn't elapse, and currently (due to bug 1347532) we will return the one with the higher resolution.
Previously since one page could only have one favicon, we were just overwriting the only favicon.
Here we can't tell if the page removed a favicon, or just added a new one, since the browser doesn't have memory of the past, and the favicon service is just handed off a new icon.

I think we don't have to do anything about this, the old favicon should disappear after a week if it's no more referenced.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.