Closed Bug 1361013 Opened 3 years ago Closed 3 years ago

stylo: style sharing bug with :first-child

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: heycam, Assigned: emilio)

References

Details

Attachments

(2 files)

Attached file test
See the attached test.
To more reliably reproduce the bug, use STYLO_THREADS=1.
I bet this is a regression from bug 1358693. Since we use the bloom filter hashes of the whole selector instead of the whole selector itself, I bet the p:first-child selector is getting fast-rejected.

I'm taking this since it's going to be easy-ish to fix, I think.
Assignee: nobody → emilio+bugs
Shouldn't have overlooked the implications of conserving the hashes when reviewing that bug!
Blocks: 1358693
Err, nope, not really, that's fine because we only slice the right of the selector, this is because we only look at the rightmost part of the selector, and now that we allow sharing between cousins, that's not enough.
Attached file Patch
I know bholley is likely to pay more attention to his bugzilla queue than to the servo one, so... :)
Attachment #8863326 - Flags: review?(bobbyholley)
Comment on attachment 8863326 [details] [review]
Patch

delegate+ in the PR.
Attachment #8863326 - Flags: review?(bobbyholley) → review+
https://github.com/servo/servo/pull/16670
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.