Changes in local image files hidden by memory cache

RESOLVED DUPLICATE of bug 137819

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 137819
16 years ago
15 years ago

People

(Reporter: era+mozilla, Assigned: gordon)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupe me 137819?, URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020206
BuildID:    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020206

I'm working on an HTML document containing PNG files and I've found that I
cannot use Mozilla for previewing because it requires me to zap the memory cache
each time I revise one of the images.

The files are in my home directory, which is locally mounted; changes to the
images are also made in a local picture editor.

When I update the text and press the Reload button, I see the updated text
immediately. With the images, I've found that even removing the images and then
recreating them by copying them back over from a backup does not cause the
browser to update its view of the pictures.

This is also true even if I do "view image" on an individual image, then press
Reload -- even then, the picture is not reloaded.

I've been struggling with this on and off for some months but it wasn't until
recently that I figured out that I could fix things by zapping the memory cache
(and so now I finally also have enough information to write a -- hopefully
useful -- bug report).

Sorry if I miscategorized this, it's not "Networking: Cache" since it's not
really a networked connection, but I guess this would be the appropriate
component for this sort of functionality anyhow.

Reproducible: Always
Steps to Reproduce:
1.Create an HTML file which refers to a PNG image file. (I'm guessing the
picture format won't really matter, though.) Store the HTML and PNG files on a
local disk.
2. View the HTML document's file:/// URL in Mozilla
3. Replace the PNG image by another one, but under the same file name. Press
Reload (before your memory cache expires, which will depend on your Cache
Preferences)

Actual Results:  Still see the old PNG file's contents

Expected Results:  Should also reload the picture

Comment 1

16 years ago
I would mark this bug as INVALID (nofix?)

The solution for your Problem is very simple:
Don't press 'Reload', press SHIFT + Reload!


you also have to do this in NS 4.x ..



Btw: the file could be stored on a smb drive or something like that and
connected over a 55k modem.. ;)

Comment 2

16 years ago
ok.. i thinkt it's okay when i mark the bug as invalid..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
REOPEN -> Image Lib
Status: RESOLVED → UNCONFIRMED
Component: Networking: Cache → ImageLib
QA Contact: tever → tpreston
Resolution: INVALID → ---
Whiteboard: dupe me 137819?

*** This bug has been marked as a duplicate of 137819 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.