Closed Bug 1361276 Opened 3 years ago Closed 2 years ago

Re-enable browser_oneOffHeader.js for OS X (gets intermittent from bug 1352364)

Categories

(Firefox :: Search, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox59 --- fixed

People

(Reporter: johannh, Assigned: arai)

References

Details

Attachments

(1 file, 1 obsolete file)

In bug 1352364 we change a lot of stuff but nothing particular to search AFAIK. browser_oneOffHeader still fails on try but we can't really reproduce it locally. It seems that this test is generally very brittle regarding timing. We'd like to avoid working on this in bug 1352364 since that one is big enough already and instead look at the test as a follow-up.
Forgot to mention that this is only on OSX.
Summary: browser_oneOffHeader.js gets intermittent from bug 1352364 → browser_oneOffHeader.js gets intermittent from bug 1352364 on OSX
Summary: browser_oneOffHeader.js gets intermittent from bug 1352364 on OSX → Re-enable browser_oneOffHeader.js for OS X (gets intermittent from bug 1352364)
this is sometimes reproducible for me.
(context: now I'm fixing bug 1416446 and others under bug 1414180, bug 1193394)

for me, mouseover event handler in synthesizeNativeMouseMove is not called and the test stops there, intermittently.
with this patch, the issue stops happening locally.
it delays the mouse event, and also move the cursor outside of the target element first, to make sure the cursor actually moves on the element.
Looks like, it's waiting for wrong event.
the actual event used in search UI is mousemove, so it should also wait for mousemove, but it's waiting for mouseover, and sometimes it's not fired.
switching to mousemove fixes local intermittent.
I'll ask review after some more tests on automation.
Assignee: nobody → arai.unmht
Attachment #8927637 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Comment on attachment 8929309 [details] [diff] [review]
Wait for mousemove instead of mouseover in browser/components/search/test/browser_oneOffHeader.js.

Changed to wait for mousemove, and removed skip-if
Attachment #8929309 - Flags: review?(jhofmann)
Attachment #8929309 - Attachment description: (WIP) Wait for mousemove instead of mouseover in browser/components/search/test/browser_oneOffHeader.js. → Wait for mousemove instead of mouseover in browser/components/search/test/browser_oneOffHeader.js.
Comment on attachment 8929309 [details] [diff] [review]
Wait for mousemove instead of mouseover in browser/components/search/test/browser_oneOffHeader.js.

Review of attachment 8929309 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you for taking care of this!
Attachment #8929309 - Flags: review?(jhofmann) → review+
Pushed by arai_a@mac.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ae9e1ead6772
Wait for mousemove instead of mouseover in browser/components/search/test/browser_oneOffHeader.js. r=johannh
https://hg.mozilla.org/integration/mozilla-inbound/rev/ae9e1ead6772ccc0e7d201f67cc786fe76e53bdd
Bug 1361276 - Wait for mousemove instead of mouseover in browser/components/search/test/browser_oneOffHeader.js. r=johannh
https://hg.mozilla.org/mozilla-central/rev/ae9e1ead6772
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.