Don't try to open the favicons database on startup for existing profiles

RESOLVED FIXED in Firefox 55

Status

()

P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

(Blocks: 2 bugs)

unspecified
mozilla55
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox55 fixed)

Details

(Whiteboard: [fxsearch][qf:p2][reserve-photon-performance])

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
things to do:
1. let's rely on ATTACH call succeeding rather than trying to detect corruption by opening/closing the db
2. in any case let's use asyncClose() to close the connection
3. in case of corruption, mark in a property which database was corrupt, places.sqlite or favicons.sqlite and then try to replace only that one
(Assignee)

Updated

2 years ago
Blocks: 1361091
Blocks: 1348289
Whiteboard: [fxsearch][qf] → [fxsearch][qf][photon-performance]
Flags: qe-verify?
Priority: P1 → P2
(Assignee)

Updated

2 years ago
Blocks: 492172

Updated

2 years ago
Whiteboard: [fxsearch][qf][photon-performance] → [fxsearch][qf:p1][photon-performance]
No longer blocks: 1348289
(Assignee)

Updated

2 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Priority: P2 → P1
Whiteboard: [fxsearch][qf:p1][photon-performance] → [fxsearch][qf:p1][reserve-photon-performance]
Comment hidden (mozreview-request)
(Assignee)

Comment 2

2 years ago
hrm, Try is unhappy for some reason.
(Assignee)

Updated

2 years ago
Attachment #8871249 - Flags: review?(adw)
(Assignee)

Comment 3

2 years ago
New build to check if the issue is due to AsyncClose. My theory is that by the time we reach the ATTACH QUERY asyncClose is still running and it's not possible to ATTACH during a transaction (close is not a transaction, but I suspect part of it may work similarly). This may be compatible with the fact the previous patch was only failing on Linux, it's a different scheduler. Let's see. https://treeherder.mozilla.org/#/jobs?repo=try&revision=931128ae7453e2180aea1bc72f6b78dc2bb37077
Comment hidden (mozreview-request)

Comment 5

2 years ago
mozreview-review
Comment on attachment 8871249 [details]
Bug 1361322 - Don't try to open the favicons database on startup for existing profiles.

https://reviewboard.mozilla.org/r/142738/#review146624

LGTM
Attachment #8871249 - Flags: review?(adw) → review+

Comment 6

2 years ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/6f9a72ab2e18
Don't try to open the favicons database on startup for existing profiles. r=adw
Whiteboard: [fxsearch][qf:p1][reserve-photon-performance] → [fxsearch][qf:p2][reserve-photon-performance]

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6f9a72ab2e18
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Iteration: --- → 55.6 - May 29
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.