If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

copying text from firefox is broken in linux

RESOLVED INVALID

Status

()

Core
Widget: Gtk
--
major
RESOLVED INVALID
6 months ago
5 months ago

People

(Reporter: Hussam Al-Tayeb, Unassigned)

Tracking

54 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170502232935

Steps to reproduce:

I am using the 54 branch of firefox and the latest gtk+ 3-22 branch,
Copying text from firefox is broken.

The following procedures don't work:
1) Copying text from firefox to firefox.
2) Copying text from firefox and pasting in a native gtk+ application.

The following procedures work:
1) Copying text from a native gtk+ application and pasting in firefox.
2) Copying text from a native gtk+ application and pasting in another native gtk+ application.
3) Copying an image in firefox (whole image, not the link) and pasting it in another application such as gimp.

Please make sure you are using the latest code from gtk+ 3.22 branch before testing my bug.
(Reporter)

Updated

6 months ago
Severity: normal → major
Component: Untriaged → Widget: Gtk
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

6 months ago
This is the relevant gtk+ change. https://bugzilla.gnome.org/show_bug.cgi?id=781814
Perhaps firefox needs to adapt to it.
Note: Libreoffice, webkitgtk+, and native gtk+ applications are not affected.
(Reporter)

Comment 2

5 months ago
gtk+ 3.22.13 was released with this change. It looks like firefox needs to support "text/plain;charset=utf-8" in addition to the currently used UTF8_STRING.
(Reporter)

Comment 3

5 months ago
GTK+ developers fixed this in 3.22.14
(Reporter)

Updated

5 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.