If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

High CPU on YouTube without video playing

RESOLVED DUPLICATE of bug 1363176

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1363176
5 months ago
4 months ago

People

(Reporter: ffbug, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170504100357

Steps to reproduce:

1. Create a new profile and start Nightly using it.
2. Open the page of any YouTube video. Doesn't matter if it's paused or not.
3. Scroll down until comments no longer loading and you have reached bottom.


Actual results:

Memory rapidly goes up then returns to normal. A CPU thread (i7 4700MQ) reaches 100% (by the content process) and remains there until tab is closed. Reproducible most of the time.

Captured profile: https://perfht.ml/2pMPr82


Expected results:

After the page stops loading and the video is paused/finished, CPU usage should be low.

Mozgression result:
12:58.08 INFO: Narrowed inbound regression window from [82c2d17e, 96605941] (3 revisions) to [d7e40bb8, 96605941] (2 revisions) (~1 steps left)
12:58.08 INFO: Oh noes, no (more) inbound revisions :(
12:58.08 INFO: Last good revision: d7e40bb852ea047a0e5f530bcdc04d29a1765001
12:58.08 INFO: First bad revision: 96605941c0021795376d9c6ec1e458de2fac329e
12:58.08 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d7e40bb852ea047a0e5f530bcdc04d29a1765001&tochange=96605941c0021795376d9c6ec1e458de2fac329e

Updated

5 months ago
Component: Untriaged → Audio/Video
Product: Firefox → Core

Updated

5 months ago
Component: Audio/Video → Audio/Video: Playback
(Reporter)

Comment 1

5 months ago
If I may, I don't think this is a playback issue. In fact, I was able to find that the issue won't be present if I block (using the umatrix extension) scripts from "www.google.com". There is only one javascript from this domain for me and it was on this specific link: https://www.google.com/js/bg/t25eXuZr9l7mSvN9V6HjD1Wd1Xq9FZoNok7fncZiLZc.js. In case it's inaccessible for others, I've uploaded to pastebin: https://pastebin.com/JGBGb039
(Reporter)

Comment 2

5 months ago
I apologize, the info in Comment 1 is _partly_ false. Blocking XHR of "www.youtube.com" using the same extension was what actually worked. Also, I was able to stop the issue by using an extension to block _only_ the comment section while the video was playing, therefore something is wrong with the comment section. If further info is needed, let me know.
(Reporter)

Comment 3

5 months ago
The bug isn't present in Build ID 20170510183715.

Mozregression (--find-fix) result:

8:15.34 INFO: First good revision: 8a43b69fbae255a2af98f11507862437d6303033
8:15.34 INFO: Last bad revision: ebbcdaa5b5802ecd39624dd2acbdda8547b8384d
8:15.34 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ebbcdaa5b5802ecd39624dd2acbdda8547b8384d&tochange=8a43b69fbae255a2af98f11507862437d6303033

8:16.87 INFO: Looks like the following bug has the  changes which introduced the fix:
https://bugzilla.mozilla.org/show_bug.cgi?id=1354641
ffbug,
Thanks for your help to fire this bug and keep figuring out the problem. 
Bug 1354641 is just backed out yesterday.
Could you help test today's nightly to see if this bug is fixed by that backout. 
Thanks.
Flags: needinfo?(ffbug)
See Also: → bug 1354641
(Reporter)

Comment 5

4 months ago
The issue seems to be absent in Build ID 20170511100157.
Thanks for confirming!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Flags: needinfo?(ffbug)
Resolution: --- → DUPLICATE
See Also: bug 1354641
Duplicate of bug: 1363176
You need to log in before you can comment on or make changes to this bug.