Closed Bug 1362267 Opened 3 years ago Closed 3 years ago

Replace requests are failing on Windows and falling back to normal updates

Categories

(Toolkit :: Application Update, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr45 --- wontfix
firefox-esr52 --- wontfix
firefox53 --- wontfix
firefox54 - wontfix
firefox55 --- fixed

People

(Reporter: rstrong, Assigned: rstrong)

References

Details

(Keywords: regression)

Attachments

(2 files)

It is difficult to notice since normal updates on Windows are fast but replace requests have been failing due to the current working directory being the installation directory ever since bug 1246972 landed.
Note: this wasn't caught by tests due to the test's working dir being different than the test's installation dir.
Attached patch Test patch rev1Splinter Review
I went with using env vars for the tests and the test updater. I also verified that the tests fail without the client patch.
Attachment #8864724 - Flags: review?(mhowell)
I'm going to push these to oak instead of try so I can manually test updates.
Attachment #8864725 - Flags: review?(mhowell)
Attachment #8864725 - Flags: review?(mhowell) → review+
Attachment #8864724 - Flags: review?(mhowell) → review+
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/91e80fe92625
Test code - Bug 1362267 - Replace requests are failing on Windows and falling back to normal updates. r=mhowell
https://hg.mozilla.org/integration/mozilla-inbound/rev/24ecce36f401
Client code - Bug 1362267 - Replace requests are failing on Windows and falling back to normal updates. r=mhowell
[Tracking Requested - why for this release]:
This is a regression from bug 1246972 that we didn't see due to one of app update's fallbacks to handle error conditions. This causes the Windows client to stage an update and then to fallback to a regular update which is extra work that isn't needed and it makes the time it takes to update longer. Though I would be ok with not uplifting this I think it would be good to uplift to lessen the time.
Note: the tests now cover this case.
https://hg.mozilla.org/mozilla-central/rev/91e80fe92625
https://hg.mozilla.org/mozilla-central/rev/24ecce36f401
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Hi :rstrong,
If it's ok not uplifting this, I tend to let it ride the train. Mark 54 won't fix and track 54-.
Setting this to wontfix for esr52 as well. Feel free to change the status back and nominate for approval if you feel otherwise, Robert.
You need to log in before you can comment on or make changes to this bug.