Scrollbar disappears when opening images on a Facebook group

RESOLVED DUPLICATE of bug 1363176

Status

()

Core
Spelling checker
RESOLVED DUPLICATE of bug 1363176
9 months ago
8 months ago

People

(Reporter: Serphentas, Unassigned)

Tracking

55 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox53 affected, firefox54 affected, firefox55 affected)

Details

(Reporter)

Description

9 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36
Build ID: 20170505100657

Steps to reproduce:

On a Facebook group, open an image.


Actual results:

Notice that after closing the image overlay, the scrollbar is no longer present. The page is frozen in terms of position (scroll does not work) but works functionally.

If you use the Page up/down keys, you can make the scrollbar appear again.


Expected results:

No scrollbar disappearing.
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Firefox 55.0a1, Build ID: 20170510030301

I have managed to reproduce this issue on latest Nightly build, but not only the scrollbar is affected. On a Facebook group if you keep scrolling, at some point you can observe that the older posts are loaded slowly and when you click on a image you can observe a delay until the comments are displayed.
Also if you hit the "x" button, the image is not dismissed only if you click it several times. After the image is dismissed the  page cannot be scroll and the scrollbar is displayed only after a few seconds (~5-15s). 
I was able to reproduce this issue on Mac Os 10.12, but you have to load many old posts.

I haven't managed to reproduce this issue on older versions on Nightly. Considering this I have performed a regression range using the mozregression tools. Here are the results:

Last good revision: bdc6c6d8065319c8089f7f60c0b72942dea218a4
First bad revision: 20a9d741cdf4a9e88598c8a4471677b834e70927
Pushlog: https://goo.gl/E2uumK

Looks like the following bug has the  changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1354641

Evelyn, can you please take a look at this? Is there a chance that the fix affected this behavior?

Here is a Gecko profile: https://perfht.ml/2pwnEFj
Status: UNCONFIRMED → NEW
status-firefox53: --- → affected
status-firefox54: --- → affected
status-firefox55: --- → affected
Component: Untriaged → Spelling checker
Ever confirmed: true
Flags: needinfo?(ehung)
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → x86_64

Comment 2

8 months ago
Yes, from the Gecko profile in comment 1, a lot of time spent on mozInlineSpellWordUtil.EnsureWords(). Same symptom of bug 1363176.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(ehung)
Resolution: --- → DUPLICATE
Duplicate of bug: 1363176
You need to log in before you can comment on or make changes to this bug.