Closed Bug 1362500 Opened 4 years ago Closed 4 years ago

"Profile In Use" message appears when nightly is reopened from the previous profile

Categories

(Firefox :: Untriaged, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Abe_LV, Unassigned)

Details

Steps to Reproduce:
1. Start Nightly from clean profile
2. start your local server (e.g. http://127.0.0.1:8080/)
3. Open about: config 
4. set toolkit.telemetry.server to http://127.0.0.1:8080/ 
5. Shutdown Firefox
6. Launch Nightly from the same profile
7. If you do not get "Profile In Use" message, repeat step 5 and 6

Actual Result:

"Profile In Use" message appears even though the browser is closed (at least visually). I think another process is using the profile.

Expected Result:
Browser should be able to relaunch from its previous profile

Screen capture: https://testing-1.tinytake.com/sf/MTU3NTE4Ml81NDAyODA1

Test Environments:

Windows 7 x86 with 32 bits of latest nightly
Flags: needinfo?(alessio.placitelli)
I assume this was from testing the pingsender?
Can you reproduce the same issue without the pingsender being active?
Flags: needinfo?(amasresha)
Summary: "Profile In Use" message appears when nightly is being reopenned from the previous profile → "Profile In Use" message appears when nightly is reopened from the previous profile
(In reply to Georg Fritzsche [:gfritzsche] from comment #1)
> I assume this was from testing the pingsender?
> Can you reproduce the same issue without the pingsender being active?

It is not reproducible if toolkit.telemetry.enabled;false.
But it is reproducible with toolkit.telemetry.shutdownPingSender.enabled;false.

When it is reproducible, the browser also crashes intermittently.
Here is one of the crash IDs ( I will investigate this more):
bp-7141e4d5-e46b-42a7-9257-f8b720170508


Screen capture:https://testing-1.tinytake.com/sf/MTU4NTY4OV81NDIzNTUw
Flags: needinfo?(amasresha)
Test environments:
OS:
Windows 7 x86 in VirtualBox.

Browser:
Version 	55.0a1
Build ID 	20170508030204
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 6.1; rv:55.0) Gecko/20100101 Firefox/55.0
(In reply to Abe - QA (:Abe_LV) from comment #2)
> (In reply to Georg Fritzsche [:gfritzsche] from comment #1)
> > I assume this was from testing the pingsender?
> > Can you reproduce the same issue without the pingsender being active?
> 
> It is not reproducible if toolkit.telemetry.enabled;false.
> But it is reproducible with
> toolkit.telemetry.shutdownPingSender.enabled;false.

After looking over the screen capture again and given your new tests, it seems like this is more generally tied to the browser shutdown rather than to specifically to the pingsender: this is happening with the pingsender being disabled.

This seems to be happening because, even though the FF UI is not shown, FF is still shutting down and you're trying to start it up again.

I've removed it from the blocker list of the shutdown pingsender.
No longer blocks: 1356673
Flags: needinfo?(alessio.placitelli)
This should be expected behavior when quickly shutting down and starting Firefox again.
Component: Telemetry → Untriaged
Product: Toolkit → Firefox
Closing this as Works-For-Me, as it is expected behavior, comment 5.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.