Remove services/sync/locales/en-US/errors.properties

RESOLVED FIXED in Firefox 55

Status

()

enhancement
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: eoger, Assigned: jomer14, Mentored)

Tracking

({good-first-bug})

unspecified
Firefox 55
Points:
---

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
I thought I removed this but it turns out I didn't. It is not used anymore.
(Reporter)

Updated

2 years ago
Summary: Remove error.properties → Remove services/sync/locales/en-US/errors.properties
Mentor: eoger
Keywords: good-first-bug

Comment 1

2 years ago
I think I might be interested in this bug as it seems simple enough for someone who has not had any experience fixing them. First, just so I understand, is this removing the entire errors.properties file from en-US?
Flags: needinfo?(eoger)
(Reporter)

Comment 2

2 years ago
Hello nbeltran14,

Yes you are correct. We also need to remove the references to that file:
- browser/base/content/test/static/browser_all_files_referenced.js contains a reference.
- services/sync/locales/jar.mn also contains another.

Thanks for picking this up!
Flags: needinfo?(eoger)

Comment 3

2 years ago
I'm planning to push a patch, but before I do that I'm going to create a new patch holder using Mercurial's hg qnew command. Is it preferable to state in the message that the mentor of the bug be the one to review the patch? I'm still very new to this.
Flags: needinfo?(eoger)
(Reporter)

Comment 4

2 years ago
Yes, for simplicity I will be the one to review your patch.
Your commit message should follow the following format:

Bug <Bug number> - <What your commit accomplishes (not the way you do it!)>. r?<reviewer(s)>

For example, for this bug your commit message should be something like:

Bug 1362510 - Remove errors.properties and references. r?eoger
Flags: needinfo?(eoger)
(Assignee)

Comment 5

2 years ago
Hi I am a team mate of nbeltran14 in class. We are working together on this bug and I was just letting you know that you may receive a patch from me.

Comment 6

2 years ago
(In reply to jomer14 from comment #5)
> Hi I am a team mate of nbeltran14 in class. We are working together on this
> bug and I was just letting you know that you may receive a patch from me.

I can confirm that jomer14 is a class mate of mine and that we are working together on things.
Comment hidden (mozreview-request)
(Reporter)

Comment 8

2 years ago
mozreview-review
Comment on attachment 8866894 [details]
Bug 1362510 - 'Remove errors.properties and references.'

https://reviewboard.mozilla.org/r/138512/#review141726

Almost there, change the commit message and we're good to go. Thanks!

::: commit-message-b9bd7:1
(Diff revision 1)
> +bug1362510 - 'Removed errors.properties and references because the file is no longer in use.' r?eoger

Please follow the model I described in comment 4
Attachment #8866894 - Flags: review?(eoger)
(Assignee)

Comment 9

2 years ago
So do you want it exactly the way you have it typed in comment 4? As in "Bug 1362510 - Remove errors.properties and references. r?eoger" Thanks!
Flags: needinfo?(eoger)
(Reporter)

Comment 10

2 years ago
As long as you respect the format [0] and your commit message makes sense I'll accept it.
Check-out the other commit messages with |hg log -l 30| if you need more examples.


[0] Bug <Bug number> - <What your commit accomplishes (not the way you do it!)>. r?<reviewer(s)>
Flags: needinfo?(eoger)
Comment hidden (mozreview-request)
(Reporter)

Comment 12

2 years ago
mozreview-review
Comment on attachment 8866894 [details]
Bug 1362510 - 'Remove errors.properties and references.'

https://reviewboard.mozilla.org/r/138512/#review142582
Attachment #8866894 - Flags: review?(eoger) → review+
(Reporter)

Comment 13

2 years ago
Thanks!
https://hg.mozilla.org/integration/mozilla-inbound/rev/20c570b957c6
Assignee: nobody → jomer14
Status: NEW → ASSIGNED

Comment 14

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/20c570b957c6
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
You need to log in before you can comment on or make changes to this bug.