Malicious addon "privacy2browsing" needs blocklisting

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: seburo3, Assigned: jorgev)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170505100657

Steps to reproduce:

The suspect site https://m.privacy2browsing.com/ext/ features a blue "Install Now" to install a suspect add-on for Firefox.
(Assignee)

Comment 1

2 years ago
It looks like the add-on hijacks search queries sent to popular engines (Google, Ask, etc.) and redirects them to their own, presumably to gain referral credit. It doesn't appear to do anything else useful. The installation page is also very misleading in its presentation.
Assignee: nobody → jorge
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

2 years ago
Add-on ID: @safesearchscoutee
(Assignee)

Comment 3

2 years ago
The block has been staged. Andreas, please confirm and publish.
Flags: needinfo?(awagner)
The block is now live.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(awagner)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.