Amazon page load's Time to First Paint is slower in Firefox than Chrome

RESOLVED DUPLICATE of bug 1362068

Status

()

Core
General
RESOLVED DUPLICATE of bug 1362068
6 months ago
5 months ago

People

(Reporter: cpeterson, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox55 affected)

Details

(Whiteboard: [qf])

Comment hidden (obsolete)
(Reporter)

Updated

6 months ago
Summary: Amazon page load is slower in Firefox than Chrome → Amazon page load's Time to First Paint is slower in Firefox than Chrome

Comment 1

5 months ago
Here is the correct procedure for profiling:

* Load https://www.amazon.com/
* Wait for the page to finish loading
* Type "Lord of the rings" in the search box
* Time first-nonblank paint
* Record when the first non-sponsored result is painted in the correct position with its image

Note that I expect it could be important to do this from the amazon UI and not as a bare pageload, because of unload scripts, GC and whatever else.

I don't recognize the data from comment 0. Here's the data I have for the amazon search page (all means):

Chrome firstpaint: 18.25 frames/304ms
Chrome hero: 51.75 frames/862.5ms

Firefox firstpaint: 35 frames/583ms (~90% worse)
Firefox hero: 60.75 frames/1013ms (~20% worse)

This data has fairly large variance and was done against live sites, which is why I hadn't yet filed this bug report, although even with the variance we show a significant different in firstpaint.

Updated

5 months ago
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1362068
You need to log in before you can comment on or make changes to this bug.