0.93ms uninterruptible reflow at restoreHistory@resource:///modules/sessionstore/ContentRestore.jsm:123:5

RESOLVED DUPLICATE of bug 1358730

Status

()

RESOLVED DUPLICATE of bug 1358730
2 years ago
2 years ago

People

(Reporter: rjward0, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf])

(Reporter)

Description

2 years ago
Here's the stack:

restoreHistory@resource:///modules/sessionstore/ContentRestore.jsm:123:5
restoreHistory@chrome://browser/content/content-sessionStore.js:182:5
receiveMessage@chrome://browser/content/content-sessionStore.js:147:9
waitForSyncCallback@resource://services-common/async.js:98:7
makeSpinningCallback/callback.wait@resource://services-common/async.js:168:27
promiseSpinningly@resource://services-common/async.js:234:12
get changedIDs@resource://services-sync/engines.js:100:5
getChangedIDs@resource://services-sync/engines.js:950:5
pullNewChanges@resource://services-sync/engines.js:1911:12
_syncStartup@resource://services-sync/engines.js:1023:24
_syncStartup@resource://services-sync/engines/clients.js:321:5
_sync@resource://services-sync/engines.js:1802:7
WrappedNotify@resource://services-sync/util.js:161:21
sync@resource://services-sync/engines.js:723:5
_syncEngine@resource://services-sync/stages/enginesync.js:219:7
sync@resource://services-sync/stages/enginesync.js:93:10
onNotify@resource://services-sync/service.js:1080:7
WrappedNotify@resource://services-sync/util.js:161:21
WrappedLock@resource://services-sync/util.js:117:16
_lockedSync@resource://services-sync/service.js:1070:12
sync/<@resource://services-sync/service.js:1062:7
WrappedCatch@resource://services-sync/util.js:92:16
sync@resource://services-sync/service.js:1051:5
Component: Untriaged → Session Restore

Updated

2 years ago
Flags: qe-verify?
Priority: -- → P2
This layout flush is happening because we're doing a nsIWebNavigation.stop - which is the same as bug 1358730.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358730

Updated

2 years ago
Flags: qe-verify?
Priority: P2 → --
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf]
You need to log in before you can comment on or make changes to this bug.