Intermittent test_navigation.py TestBackForwardNavigation.test_certificate_error | IOError: Process killed because the connection to Marionette server is lost. Check gecko.log for errors (Reason: Connection timed out after 360.0s)

RESOLVED WORKSFORME

Status

()

defect
P3
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=97053413&repo=mozilla-inbound

[task 2017-05-06T00:45:55.484198Z] 00:45:55     INFO -  TEST-START | test_navigation.py TestBackForwardNavigation.test_certificate_error
[task 2017-05-06T00:54:01.966876Z] 00:54:01 CRITICAL -  mozdevice Timeout exceeded for _runCmd call '/home/worker/workspace/build/android-sdk18/platform-tools/adb -s emulator-5554 shell ps'
[task 2017-05-06T00:54:32.000251Z] 00:54:31 CRITICAL -  mozdevice Timeout exceeded for _runCmd call '/home/worker/workspace/build/android-sdk18/platform-tools/adb -s emulator-5554 shell ps'
[task 2017-05-06T00:55:02.032878Z] 00:55:02 CRITICAL -  mozdevice Timeout exceeded for _runCmd call '/home/worker/workspace/build/android-sdk18/platform-tools/adb -s emulator-5554 shell ps'
[task 2017-05-06T00:55:32.098379Z] 00:55:32     INFO -  mozdevice Timeout exceeded for _checkCmd call '/home/worker/workspace/build/android-sdk18/platform-tools/adb -s emulator-5554 shell echo'
[task 2017-05-06T00:55:32.170689Z] 00:55:32  WARNING -  TEST-UNEXPECTED-ERROR | test_navigation.py TestBackForwardNavigation.test_certificate_error | IOError: Process killed because the connection to Marionette server is lost. Check gecko.log for errors (Reason: Connection timed out after 360.0s)
[task 2017-05-06T00:55:32.170784Z] 00:55:32     INFO -  Traceback (most recent call last):
[task 2017-05-06T00:55:32.170864Z] 00:55:32     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_harness/marionette_test/testcases.py", line 197, in run
[task 2017-05-06T00:55:32.170907Z] 00:55:32     INFO -      self.tearDown()
[task 2017-05-06T00:55:32.170986Z] 00:55:32     INFO -    File "/home/worker/workspace/build/tests/marionette/tests/testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py", line 50, in tearDown
[task 2017-05-06T00:55:32.171042Z] 00:55:32     INFO -      self.marionette.timeout.reset()
[task 2017-05-06T00:55:32.171122Z] 00:55:32     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/timeout.py", line 107, in reset
[task 2017-05-06T00:55:32.171177Z] 00:55:32     INFO -      self.script = DEFAULT_SCRIPT_TIMEOUT
[task 2017-05-06T00:55:32.171252Z] 00:55:32     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/timeout.py", line 60, in script
[task 2017-05-06T00:55:32.172062Z] 00:55:32     INFO -      self._set("script", sec)
[task 2017-05-06T00:55:32.172633Z] 00:55:32     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/timeout.py", line 33, in _set
[task 2017-05-06T00:55:32.173002Z] 00:55:32     INFO -      self._marionette._send_message("setTimeouts", {name: ms})
[task 2017-05-06T00:55:32.173692Z] 00:55:32     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/decorators.py", line 28, in _
[task 2017-05-06T00:55:32.174321Z] 00:55:32     INFO -      m._handle_socket_failure()
[task 2017-05-06T00:55:32.175087Z] 00:55:32     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/decorators.py", line 23, in _
[task 2017-05-06T00:55:32.175587Z] 00:55:32     INFO -      return func(*args, **kwargs)
[task 2017-05-06T00:55:32.176234Z] 00:55:32     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 727, in _send_message
[task 2017-05-06T00:55:32.176384Z] 00:55:32     INFO -      msg = self.client.request(name, params)
[task 2017-05-06T00:55:32.176865Z] 00:55:32     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/transport.py", line 284, in request
[task 2017-05-06T00:55:32.176992Z] 00:55:32     INFO -      return self.receive()
[task 2017-05-06T00:55:32.177426Z] 00:55:32     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/transport.py", line 211, in receive
[task 2017-05-06T00:55:32.177820Z] 00:55:32     INFO -      raise socket.timeout("Connection timed out after {}s".format(self.socket_timeout))
[task 2017-05-06T00:55:32.177899Z] 00:55:32     INFO -  TEST-INFO took 576684ms
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1341466
Lets keep it open for tracking purposes in Treeherder.
Depends on: 1341466
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: gbrown → nobody
Priority: -- → P3
This failure shouldn't come up anymore given the patch on bug 1341466 landed.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
OS: Unspecified → Android
Hardware: Unspecified → ARM
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.