On startup, the home page can still be loaded and displayed before session restore replaces it

RESOLVED DUPLICATE of bug 1054740

Status

()

enhancement
RESOLVED DUPLICATE of bug 1054740
2 years ago
2 years ago

People

(Reporter: dao, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Bug 893061 and bug 1054740 helped prevent some scenarios but didn't completely solve the issue, see bug 1054740 comment 53.
(Reporter)

Updated

2 years ago
Whiteboard: [photon-performance]
Flags: qe-verify?
Priority: -- → P2
Priority: P2 → P3
Whiteboard: [photon-performance] → [reserve-photon-performance]
Flags: qe-verify? → qe-verify-

Comment 1

2 years ago
There seems to be a slew of bugs attached to this root cause of loading the home page in the browser by default when session restore is chosen, with a bunch of attempted solutions to work around the problem with changing how tabs are restored, but isn't the simplest solution to take care of everything resolving Bug 1371884 (since the issue there is simply a failed attempt at fixing this) and instead doing a check on what the user has chosen for startup option, and if it is "restore session" always returning "true" for willOverrideHomepage() (since it will be overridden once the session store file has been loaded) or simply defaulting to "about:blank" in this case instead of the home page in _getUriToLoad, in browser.js?

That would effectively solve all the timing-critical issues that are seen now, make session restore a lot simpler, and likely browser startup faster in any scenario, to boot.
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
No longer depends on: 1054740, 893061
Resolution: --- → DUPLICATE
Duplicate of bug: 1054740
Flags: qe-verify-
Priority: P3 → --
Whiteboard: [reserve-photon-performance]
You need to log in before you can comment on or make changes to this bug.